Battle.net button not lighting up, can't get online


#4

Same here, 30 seconds and still grayed out.


#5

Been playing with my VPN and connected to IP’s from countries around the world.
Europe and US works fine, but countries in Asia and in the middle east cannot connect for some reason. why?
Please fix this! @Blizzard tnx :slight_smile:


#6

hope someone emailed newclassic@blizzard.com about it, I’m too lazy for that.


#7

yeah i’m having the same damn problem


#8

yeah also enduring this problem


#9

Asia thing makes sense, I’m in Australia.
Perhaps if we had an oceanic server (with a player pool of 20 haha)


#10

Same issue here.

The problem started around an hour ago,I’ve tried reinstalling/restarting and deleting cache,


#11

i also play in aus haha


#12

anyone know how to change the realm without wc3 laucher?
seem like who ever was in us west cant join, other server can


#14

Zoro, all realms seems to work fine, that’s not the issue. if u change your IP to a country in Europe for example, it works perfectly and you will be able to join any realm you want (including Asia and Korea, I’ve tried it), so its an IP problem. Apparently they block (for a god damn reason) everyone with an IP originated in Asia, Australia and the middle east (guys, please tell us if you can’t join outside than these regions).

P.S
Dear @Blizzard, we deserve some answers on this. at least make a statement about this issue or something.


#15

working perfectly yesterday now seem like aus got banned, thanks
PS maybe we getting Oceania server?


#16

For now you can use a free VPN (eg. windscribe) to change your IP to a US address.


#17

Same case here, working fine yesterday. Greyed out today


#18

it the ip ban i used takeaway VPN and it worked got into bnet but lagging so cant play, but at least got into bnet with VPN


#19

ditto; same thing happening to me (I can’t login the login tab is greyed-out) what’s up?!?! I am not tech-savy so I’m not installing third-party programs et cetera (nor will I adjust settings) someone please fix this issue. Thank you. :slight_smile:


#20

New Zealand player here, button to log onto battle.net is greyed out for me. Sooo lame. Why no responses from Admin?


(Mark Chandler) #21

Hi All,

We had a small server issue preventing the Battle.net button from activating. It should be fixed now and we will endeavor to fix the underlying problem to prevent it happening again.

Thanks,

Classic Games


#22

Wah thank you - it was a bad surprise this morning. Appreciate acknowledgement and fixing <3


#23

Thanks mark, working now :slight_smile:


#24

My battle.net button is grey… I’m running Warcraft 3 version 1.30.3.11235