Anyone got 1.30.2 working on Linux (WinE)?


#1

I’ve tried with WinE-staging and PlayOnLinux, but I get this.

I tried using native dbghelp dll, but no luck.


Can we expect Warcraft 3 Reforged to work on Wine+DXVK (or natively)?
#2

No luck yet here either.


#3

Update: I get it to install (partly?), but when I try to run I’m now presented with an unresponsive grey window titled “Warcraft III CDKey Required”. X closes it.

  • Wine Staging 32bit Win7.
  • Xubuntu 18.10.
  • RX 480 via Padoka PPA.
  • Wine config from xhttps://linoxide.com/linux-how-to/install-blizzard-battlenet-app-linux/
  • Additional drivers from xhttps://translate.google.com/translate?hl=en&sl=fr&u=https://doc.ubuntu-fr.org/warcraft3&prev=search

Anyone got it working? or got any further?


#4

If I run wine w3setup.exe -opengl with sudo I get to choose language, but then it fails on agent not being able to connect.

Cmon blizz, fix the installer for us linux users


#5

So I got the game to run… the quick and dirty way I did it was to use Lutris to install Overwatch. It will basically install Battlenet and you can choose to install Overwatch or not, I only want the wine-prefix it created.
I then choose to run an exe from within the prefix, choose the 1.30.2 version installer. It will install successfully and then I also got the grey screen. I moved the windows out of bounds of my screen and back into view which refreshed the content and I could click on Digital version (and not CD-Key). Move out of bounds and back and I can enter my Battlenet credentials. Move out of bounds and back and I can verify my account etc. etc…

Game launched fine, was stuck at 1024x768 but I am sure someone here knows the fix for that :smiley:

edit: Manjaro 18.x
nvidia 1060
410.x driver


#6

That … is the weirdest solution I’ve seen in, like, 3 years. TYVVVVVVVM.


#7

Happy accidents happen (think penicillin) :stuck_out_tongue:


#8

hi people.

everything works fine for me.

ubuntu 16.04 & wine-staging 3.13.2

please try this wine-version if you have issues.


#9

Thanks for the lutris tip, got me on the right track.
My problem was that I’m running bumblebee and it doesn’t have vulkan support, new battle net requires some vulkan calls which were crashing it after few seconds. So I’ll just expand on solution by @nlsthzn, this is for nvidia graphic card holders on notebooks

-Battlenet needs to run before launching w3.exe installer, so :

  1. install nvidia-xrun (for full vulkan support on notebook)
  2. configure nvidia-xrun RC script to run some desktop WM (from arch wiki guide on nvidia-xrun)
  3. Install Lutris, and launch it from nvidia-xrun environment, then launch the overwatch install script (using 3.21 tkvg wine)
  4. Battlenet installation starts going, get a crash on the way that didn’t kill installer, so it went through fine
  5. launched w3.exe digital installer
  6. the screen was grey, used nlsthzn suggestion of moving window out of screen bounds to see what is in there (it accepts input even though you don’t see it)
  7. entered the code and launched the game

Pretty epic journey, but works (with some fps drops)


#10

Also you get this error when battlenet is not running in the background


#11

Maybe my little trick helps someone (although I’m a little afraid Blizzard will find a way to destroy this workaround too if they didn’t thought of this themselves already…)

If you have access to a windows installation (make a virtual machine with a test version of windows 10 for example) just overwrite your wc3 wine installation with the files of the windows installation.
Worked flawless for me.

Oh and by the way, I use Arch! :smiley:


#12

With the latest hotfix I get “wrong installation folder” allowing me not to proceed in the installation of the patch. Anyone know how to fix this?


#13

Do you have battle net and warcraft installed in same prefix ? Is the w3 launcher in the correct folder with w3 installation ? Maybe just clean install will work


#14

BTW! If you need to update Wc3 it works the same. Run the Battlenet-App and then Warcraft 3 Launcher within the Battlenet-App prefix and it should work.


#15

I tried your method and It works, moving the window out of bounds makes it refresh, but in my case the installer will not respond to the mouse T.T


#16

Moving the window out of bounds solves it for me, thanks!!


#17

When I try this I still get the connection error and I can’t move the windows out of bounds - it is stuck in my screen.

EDIT: Holymoly - you have to launch the battlenet app before executing the installer. I should rtfm. Thanks all!


#18

!!! THX !!!
this is working!!!


#19

As the installation is running in the background. I have time to write how it worked for me.

  1. GET LUTRIS and install AAALLL the games
  • Install Battle net
  • Install Warcraft 3 RoC&TFT (I did it with CDs and oldschool reallife keys)
  1. Get Nvidia Vulkan up and running correctly.
  • there will be an error code if you start battlenet with lutris for the first time. follow the link and get all your drivers set up accordingly (lutris/wiki/How-to:-DXVK)
  1. Open Warcraft through battlenet
  • Right-Click battlenet (in lutris) and click “open exe with prefix”. then you go to the fake C_drive folder where warcraft3 is installed by lutris and choose war3.exe
    *your warcraft3 sould be somewhere like /home/yourname/games/warcraft_iii-reign-of-chaos/drive_c … and so on
  1. Warcraft 3 sould open up and tell you about relocating your data. alright
  2. Click on Battlenet and wait for the magic to happen
  3. After installing push the grey window out of the screen. MAAAGIIIC its like those old school scratchy lotto tokens.
  4. Get your CD keys ready
  5. Profit

this is the only way how I could achieve it.
Thanks to especially this forum and “Anachron” <3 <3 <3


#20

I can confirm that it has been working for me. I googled how to do it, and they said to install wine staging. I did that, then I installed Battlenet app first, then it works great as long as the Battlenet app is running.

I was able to install the game, and update it. There was the black window asking for CD key, but because I saw this same popup on Windows, I clicked in the blackness, knowing where the fields were, and the interactivity still worked – the window was just painting as black instead of visible. But once that’s over, the rest of the actual game works fine.


Wc3 - Reforged playable with Linux?