1.32.3 Broke Item Stacking

Item stacking no longer works in 1.32.3. The change log says something was adjusted, but now no consumable items stack.

Please release a hotfix quick! The map I develop for is nearly unplayable without item stacking.



Hello there; I’ve ben experiencing the same issue as Alex; and this needs DIRE fixing. Immediately. Please Blizzard, anything you can do is awaited for.

1 Like

Hello! Please follow these steps and let me know if it fixes the issue for you:

  1. In the World Editor go to Advanced -> Gameplay Constants
  2. Check the “Use Custom Gameplay Constants” box.
  3. Change “Inventory - Enable Item Stacking” from False to True


1 Like

Hi Torelef,
Thanks for the quick reply. That made no difference, items are not stacking. Also, my map uses a ton of item swapping, all item swapping appears to be broken too. People buy dummy items from shops, that instantly get swapped based on criteria, and that is all broken. Now the item get’s purchased, removed, but the new item is not returned.

EDIT: So looks like maybe just EVENT_UNIT_PICKUP_ITEM and EVENT_UNIT_DROP_ITEM might be broken? I forgot my map doesn’t stack items, based on the item acquired, it will set charges on one of them, and then remove the other. None of those mechanics are working.

This is game breaking to my map. Please revert the changes as soon as you can.

1 Like

Would be better if they fixed the bugs rather than reverting to the still broken old behaviour.

I recommend making a demonstration map showing the issue. Such as items on the ground which can be manipulated and the events not firing when they should. This way the Blizzard developers can debug it and verify that they fixed the issue.

1 Like

Dr Super Good and I have been digging into this. It seems like it might be related to GetManipulatingUnit returning null. Not sure yet if that is the full issue, but that’s definitely one major one.

The issue appears to be with the specific unit event EVENT_UNIT_PICKUP_ITEM. The event response unit is returned as null and the event response item is a handle ID but returns nonsense values if manipulated by other functions (not a real item?).

SWAT Aftermath heavily uses this event which is why it is so badly broken at the moment.

The generic player event EVENT_PLAYER_UNIT_PICKUP_ITEM appears to be working correctly. Both event response unit and item are returned as expected. Before 1.32.3 both events worked the same with regard to event responses.

I am unsure if this is the only specific unit item event that was broken by 1.32.3.

1 Like

I appreciate alot the fact that people have been looking into this further and providing information; since it’s actually a big issue affecting small time map makers. Much hearts to you all.

I hope this gets resolved soon.

This also worked like a charm in my map; and is much appreciated. I never noticed that option or if it was functioning properly or not before. Thank you very much Torelef.

1 Like

This was added in 1.32.3 I think.

I’m glad the steps i provided are helping some. We are investigating the other issues reported here as well. We appreciate all the info everyone.

1 Like

Thank you, Torelef. This was bugging the heck outta me. There’s another problem where doing this will disable the Melee ruleset for maps, my map used it. Oh well, I’ll revert it to melee manually.

Hi Torelef, thanks so much for investigating it! Do you know if a hotfix is planned/possible? This is a huge bug that is game breaking to any map that uses unit events for items.

If possible, a hotfix would be greatly appreciated. None of my users can play the game anymore, and the once-a-month planned patch would be a long time to wait for something that is game-breaking. :frowning:

1 Like

I doubt that doing this fixed their problem. There are hundreds of maps out there that use item stacking and are being negatively impacted by this. Please revert back to the way it was.