1.31.0 FPS/Crash fix.


#1

For some reason ( ̶W̶C̶3̶ ̶R̶e̶f̶o̶r̶g̶e̶r̶e̶d̶) warcraft 3 using Directx11 by default. That absolutely does not make sense and causes a bunch of problems, especially on old devices.

So to fix 5fps problem or crashes, we need to switch back to DX9 or OpenGL

  1. Open your game folder (D:\Games\Warcraft III)
  2. Open x86_64 folder (D:\Games\Warcraft III\x86_64)
  3. Click right mosue button on Warcraft III.exe and press “create shortcut”.
  4. Right mouse button on shortcut > Properties
  5. Add " -graphicsapi Direct3D9" do the object field, so u will get smth like

“D:\Games\Warcraft III\x86_64\Warcraft III.exe” -graphicsapi Direct3D9

  1. Launch game from this shortcut

Warcraft PTR 1.31 lag fix
Is there a way to "un-do" the lastest patch? My PC is so laggy now i cant play
#2

Didn’t work for me. Unit animations seem very low FPS still for some reason.


#3

I’m running this on my 8 year old desktop under Linux with Vulkan via DX11 and DXKV.

I’m getting about 170 to 200 FPS and it is very smooth.


#4

it works thank you <3


#5

same problem, not working for me - i have about 30 fps, i had about 60 - 70 … now unplayable :frowning:


#6

worked for my friend thank you very much. pls share and bump


#7

Thanks man! I appreciate!


#8

Unfortunately, blizzard might drop support for Direct3D 9 like they did for their other games. check patch notes

I hope this will never happen. This is the only way I fixed FPS problem in this patch.


#9

Worked perfectly, i was fps 6 now im 120 fps. and before patch i was 60!


#10

when you say add -graphicsapi Direct3D9 to the object field, which one is the object field, i don’t see something that says object field on the shortcut properties


#11

There is another option. Dual booting Linux is easy and the game runs great under Linux.


#12

After I put this in the target field, it does not allow me to save it. Doesn’t recognize it as a legitimate entry. Dunno what I’m doing wrong, seems straightforward. Game keeps crashing on every load screen. Can someone clarify or suggest another solution?


#13

you need to place it at the end of the command line, after the "


#14

i try to put it like this: “C:\Program Files\Warcraft III\x86_64\Warcraft III.exe”-graphicsapi Direct3D9 and i cant save it. it says that its invalid. What am i doing wrong? i could previously (pre patch) play perfectly fine on my laptop and now it doesnt work…


#15

it must be “C:\Program Files\Warcraft III\x86_64\Warcraft III.exe” -graphicsapi Direct3D9

a space after the ”