Unable to connect via lan

Me and my fiancée are trying to play SC:R via LAN and prior to updating her account to remastered we were able to games that she had created but not ones that I created with remastered. Now that both accounts are on remastered we can not see LAN game that either of us create. It is disappointing that there is this issues with LAN games on what should have been just a graphics update on a 23 year old game


If you want to LAN, you’ll probably want to use patch 1.16.1. I keep a separate installation for that very purpose.

The gotcha with LAN is that you need to both be on the same subnet. 1.16.1 won’t help to resolve that, it’s always been this way. You may have more luck using Battle.net, as it does not have this limitation.

I have the same issue: when we create a LAN game on one computer the opponent is unable to see it on his computer. Has anyone managed to solve it?

1 Like

bull, I have tried every solution offered, both my pc’s are on the same subnet, 1 number appart in the IP configuration, both games paid for and still NO LAN, shame on you blizzard.


I think back in the day, it was easiest to get it working using peer-peer networking with a direct ethernet connection between 2 pcs. You will need a twisted pair cable. Also, as mentioned, just set static IPs and same subnet.

I haven’t tried it since 1.16 however.

How do you install an old version of the game to get LAN working again? Since no LAN is working anymore for any of us.


confirm, it did install, we can see each other when creating lan, but join is no more possible…


11 posts were merged into an existing topic: Cannot create LAN games - blank windows result