SC won't open for me

So basically, every time i try to open the game, it hits me with an error, and i dunno what to do, if you could take this report key or whatever its called, and point me in the right direction, that would be of much assistance, thanks in advance
704B33C6-B7B3-417A-8F0D-5FEA3D541089

Hey, laserguyman! This crash is a permission related or something blocking or causing issues with connecting with the cloud data. Does the same thing happen on a New Admin account?

If not, try pressing Windows Key + R, and type in %appdata%/blizzard/starcraft try moving this folder over to the desktop, and relaunch the game. It should regenerate the files needed. If not, try moving the folder back into the %appdata% location.

You could also try deleting CSettings.json from your Documents/StarCraft folder. That will delete your local settings file, but it will be downloaded again from the cloud on login.

alright, i’ll try both of these, thanks
Edit: I tried them both, but it was the second one that worked, Thanks again for the help!

A post was merged into an existing topic: Saghalie - Can’t launch game