Patch 1.23.2 Notes

I can confirm: using the new patch I see no more “Download failed” thing, no more blank menus, no more slow UI. I’m using Linux (SC running under wine-staging, Win7 compatibility settings).

On Win7 native host and patch, I wasn’t able to reproduce any of the aforementioned issues.

I don’t want to speculate, but it looks to me that something terrible going on inside UI threads. My thoughts that wine introduces significant delays when processing various events and a UI subsystem don’t expect that. Lack of proper synchronization and race conditions? Probably that’s what happening on some Win machines as well?

Nevertheless, given the profile of bugs you’ve discovered I strongly against bringing back the new CEF (I suppose this is a component you’ve updated?) into the SC just for “compatibility reasons”. I encourage devs looking into this thread to fix bugs or at least provide decent workarounds.

Otherwise, it is a matter of time when this will hit my Win7/Win8/Win10 machines as well.

Since last patches “pillar box” in HD mode causes loss of ~50fps. Is it normal? Shouldnt 4:3 mode require less resources?

Looks like these are read errors (files not found). Have you tried scan & repair? Or reinstalling the game?

There is something wrong with the servers, lot of people can’t login. Do you have an estimate when this will be fixed?
(when the blizzard app finally manages to login, starcraft doesn’t see it, so it wants to login as well and gives an error)

There is a login issue affecting many Blizzard games in EU at the moment. It’s being worked on, and will hopefully be resolved soon.

1 Like

So it’s not the patch. Thanks for the info!

We just deployed to address a couple of issues with the chat window (auto scroll and copy text).


Grant, we appreciate your work, as much as I like to grumble in my posts and my incendiary comments on Bnet. Muchos kudos for getting this out even so close to Thanksgiving.

Having tested this a bit I might suggest not forcing a scroll if the user scrolls up, but NBD.

Not sure if it’s just my Mac, but when I launch Starcraft, I get a message popping up saying an upgrade to version is required for online play. When I click the upgrade button, Starcraft closes, and nothing happens.

I’ve tried restarting the app as well and it still won’t work. App is sitting at version

I’m having the exact same problems as AngryProbe above (Except on a PC with Windows 10). I’ve also talked with a few other people that seem to be experiencing the same problem - the patch doesn’t apply and StarCraft closes so we can’t get online.

1 Like

New patch made game playable at last, thanks Matt and Grant. And by the way, can you bring back Cyan please?

Is this to fix the in-game chat history auto-scroll? fingers crossed
Or is it for something else?

every time I get into the game it says upgrade required but I already did so it just kicks me out and says its done then it says upgrade again

having to uninstall a game to apply an update…


I think I figured it out - you have to clear your cache folder. Mac is a little different than PC, but this might be the steps you need

1 Like

Uninstalling and re-installing worked for me. Might try cache folder deletion before going through a 5GB download.
I do think its really great that the Windows ME team was hired by Blizzard to code SC1 updates. Great job!

I did all that. still cant pass by the upgrade screen. why is the game so broken just to fix a simple color change?

Looks like there is an intermittent server issue where it’s not reading the correct version number. It’s being worked on right now.

I tried deleting the cache folder and it did not fix the issue. I see they are working on it, so I’ll try to be patient.

ok thank you for checking up on that. everything was working fine yesterday for me except the chat scroll, but i already read that has been fixed.