Patch 1.23.0 Notes

Since this last patch, when I play single player -> Play Custom, the map list is empty, on showing empty folders. Anyone else had this issue? Loading a save from single player custom game is not an issue though.

Hey everyone,

We’ve just released Maintenance patch 1.23.0.6398 which contains the following fixes:

  • Original StarCraft maps not displaying for custom games
  • Additional stability support for frequently received crashes.

thanks,
Matt

4 Likes

Can you please clear the games list. its been broken since Friday. It shows all sorts of old non existent games in there that just fail to join

Yes! StarCraft can once again be played. Thank you for solving the issue with maps not displaying in the Create screen.

Hello,
I don’t think ladder ranking has been switched back to a percentage-based system.

Hey All

We’ve just released a maintenance patch 1.23.0.6434 which includes the following fixes:

-Fixed an issue that allowed units to receive Pylon power.
-Fixed an issue with LAN/Bonjour affecting Korean IGR players
-Added extra profanity filtering for the CN Region.

thanks
Matt

1 Like

Could you give us another chance to attach our Bnet 1.0 accounts to our battle.net 2.0 StarCraft Remastered account?

Historically, legacy battlenet accounts are erased after a few months (3?) of inactivity.

2 Likes

I don’t know why I can’t update to 1.23. Normally I click play and it’’ lead me to update but this time I click play then it’ll act like it finish update. Then I’ll go into the main menu and It’ll ask me to update again. Is there something wrong on my end?

1 Like

You could try a Scan & Repair in the Blizzard launcher?

I have the exact same problem. Where is the scan & repair option?

Edit: I found it. still have the exact same issue of requiring a patch when starting SC.

1 Like

I have the same problem, i haver version 1.23.0.6398 and it says i need to upgrade to 1.23.0.6434 but it won’t do that. If i scan for updates my launcher says it’s up to date, but clearly it isn’t :frowning:

I also tried the scan & repair option but it didn’t help too. I’m playing ftom region Europe if that is any help for clearing up the problem.

1 Like

I can not upgrade either.
It is still 1.23.0.6398, but it does not try to upgrade to 1.23.0.6434.

1 Like

I just tried uninstalling and re installing it via the launcher, but sadly it didn’t help either :frowning:

Re installed it again without the automatic updates enabled and still not working :cry: (

1 Like

Same issue here! Cant make update! I scaned and repaired, now i will try unistall and install again… again… its not first time this happens i hope it will help tho as it didnt for Fudge… ;/

1 Like

Same. The Blizzard Launcher says StarCraft is up to date but I have 1.23.0.6398 and when I launch it says I need 1.23.0.6434 but the ‘UPGRADE’ button won’t take me to an update. I tried a Scan and Repair but it says there are no problems.

Edit: I just tried ‘Check for Updates’ again and it worked so now I have 1.23.0.6434

Looks like there was a minor hiccup on a patch server this morning which temporarily reverted some folks to a previous patch, but it should be back to normal now.

Still Can’t Play due to upgrade bug. When is this getting fixed? are there any work arounds? Will not allow me to patch back up when I click upgrade

upgrade worked today :slight_smile:

Hey, folks. Can you guys implement a feature that allows the players to disable chat during a game?

4 Likes