Patch 1.23.0 Notes

Something is seriously wrong with patch 1.23.0.6379. None of the maps are being shown in the Maps selection box on the Single Player -> Custom -> Create screen (even though the files exist in StarCraft/Maps/) and therefore the game cannot be played in Single Player mode. (Everything was working right before the patch happened.) (Interestingly, at least the Challenger map is available in Multiplayer mode)

Update: After uninstalling and reinstalling StarCraft (why is it 6.5GB?) the issue remains.

Update: After removing Documents/StarCraft, Uninstalling StarCraft AND battle.net, and then reinstalling StarCraft (6.5GB downloaded AGAIN) the issue remains.

Update: I can play the game by loading a saved game only. Unfortunately I had not saved a game at the very beginning, so I can play only the end of a game… that is too bad.

Update: re: system specs: I’m away from my PC right now but it’s Windows 10 on i7-4770K.

1 Like

Could you allow Real-Time Lighting to be enabled again?There were people who didn’t experience any issues with it turned on, just add a warning message like “You may experience problems with this option turned on” when people try to turn it on.

I confirm what the user “friend” said, the solo menu the original Starcraft is bugged, it is not possible to load any maps / custom maps from .scm starcraft maps because the maps files are not displayed at all.
For information, in the home menu if we select the Starcraft Broodwar then the maps are displayed.
However it is problematic because we cannot play the custom maps of the original StarCraft game anymore.
Could you please fix this bug as soon as possible?

friend and BruCe,

Can you both, please, list your System Hardware Specifications. I cannot reproduce your issues on my Hackintosh. Maps are where they are supposed to be, and Custom --> Create IS working for me.

My Specs are as follows:

Profile: iMac 18,3. (iMac 27" Retina Display, 2017.)

i7 7700K 4.2GHz, 4c/8t
Gigabyte GA-H270-HD3 MOBO
32GB Corsair Vengeance LPX DDR4-CL14 2400MHz RAM - (4x 8GB)
Fenvi FV-T919 WiFi-AC & Bluetooth 4 PCI-e x1 Card
Lite-On DVD-Burner
Silverstone FS303B 3-Bay Hot Swap Bay
Samsung 860 Pro 1TB SSD - High Sierra 10.13.6 - (17G7024), (APFS), w/Web Driver 387.10.10.10.40.128 & CUDA Driver 418.163
Samsung 860 Pro 1TB SSD - Win 7 Pro SP-1 x64
Western Digital Black 2TB HD, (HFS+), - MacOS Time Machine/Games, 1TB ea. Partition
One MacVidCards’ GTX-1070 8GB GDDR5 VRAM - Low Power - (one 8 Pin Connector)
One EVGA GTX-1050 2GB GDDR5 VRAM
SabreNT USB Audio
Rosewill NightHawk-117 E-ATX Case
Corsair HX750i Platinum 750 Watt PSU
UNITEK 10-Port USB 3.0 Hub
ASUS VE278 27" Monitor on HDMI, (1920x1080), on GTX-1070 8GB Card
Altec Lansing 45 Speaker Set
MacAlly ACEBTKey Bluetooth Keyboard
Logitech M510 USB-Fob Wireless Mouse
Logitech EXTREME 3D PRO USB Joystick

SC:R works perfectly on my System.

TimeLord04

Since this last patch, when I play single player -> Play Custom, the map list is empty, on showing empty folders. Anyone else had this issue? Loading a save from single player custom game is not an issue though.

Hey everyone,

We’ve just released Maintenance patch 1.23.0.6398 which contains the following fixes:

  • Original StarCraft maps not displaying for custom games
  • Additional stability support for frequently received crashes.

thanks,
Matt

4 Likes

Can you please clear the games list. its been broken since Friday. It shows all sorts of old non existent games in there that just fail to join

Yes! StarCraft can once again be played. Thank you for solving the issue with maps not displaying in the Create screen.

Hello,
I don’t think ladder ranking has been switched back to a percentage-based system.

Hey All

We’ve just released a maintenance patch 1.23.0.6434 which includes the following fixes:

-Fixed an issue that allowed units to receive Pylon power.
-Fixed an issue with LAN/Bonjour affecting Korean IGR players
-Added extra profanity filtering for the CN Region.

thanks
Matt

1 Like

Could you give us another chance to attach our Bnet 1.0 accounts to our battle.net 2.0 StarCraft Remastered account?

Historically, legacy battlenet accounts are erased after a few months (3?) of inactivity.

2 Likes

I don’t know why I can’t update to 1.23. Normally I click play and it’’ lead me to update but this time I click play then it’ll act like it finish update. Then I’ll go into the main menu and It’ll ask me to update again. Is there something wrong on my end?

1 Like

You could try a Scan & Repair in the Blizzard launcher?

I have the exact same problem. Where is the scan & repair option?

Edit: I found it. still have the exact same issue of requiring a patch when starting SC.

1 Like

I have the same problem, i haver version 1.23.0.6398 and it says i need to upgrade to 1.23.0.6434 but it won’t do that. If i scan for updates my launcher says it’s up to date, but clearly it isn’t :frowning:

I also tried the scan & repair option but it didn’t help too. I’m playing ftom region Europe if that is any help for clearing up the problem.

1 Like

I can not upgrade either.
It is still 1.23.0.6398, but it does not try to upgrade to 1.23.0.6434.

1 Like

I just tried uninstalling and re installing it via the launcher, but sadly it didn’t help either :frowning:

Re installed it again without the automatic updates enabled and still not working :cry: (

1 Like

Same issue here! Cant make update! I scaned and repaired, now i will try unistall and install again… again… its not first time this happens i hope it will help tho as it didnt for Fudge… ;/

1 Like

Same. The Blizzard Launcher says StarCraft is up to date but I have 1.23.0.6398 and when I launch it says I need 1.23.0.6434 but the ‘UPGRADE’ button won’t take me to an update. I tried a Scan and Repair but it says there are no problems.

Edit: I just tried ‘Check for Updates’ again and it worked so now I have 1.23.0.6434