Mature Language Filter WON'T TURN OFF!

I turned off the mature language filter in settings, but it still censors swears when I am in starcraft. It’s really annoying, does anybody know how to fix this?

Try doing it from the launcher options as well. Like the bnet launcher options and sc options.

Seems to be a new issue. Despite always having both the launcher and in-game boxes unchecked, everyone’s chat is still censored (except for my own, apparently).

Yeah my filter never resets but others do

Dealing with the same problem.

My filter options are off but curse words are still censored.

You would have better luck tweeting the developers than posting on these forums.