Map editor not saving anymore

That agent needs to be fired because your question wasn’t even about StarEdit but the game itself! Instead of helping they shutting down threads. This way devs won’t have chance seeing the issues.

Load next trigger bug is definitely editor independent - it may have to do with whether the map is in the starcraft directory or in my documents\starcraft\maps , have you tried both locations?

@Sinsanity (aka Suicidal Insanity!!) :wink:
Yes, of course, I have tried both directories. My first assumption was exactly that thought, since there is a identical handling of directories for WarCraft III, where you HAVE to place maps in Documents/WarCraft III/Maps or you will simply not find them ingame.

As you can imagine, the result is one and the same when you put a Starcraft campaign in Documents folder. Start a campaign over the “Custom Maps” menu and as soon you have finished the first map, you got instant throw back to the campaign selection screen. This one with to the left Stukov, middle Artanis, to the right Kerrigan. It’s a bug and they have to fix it.

This also applies when you use the original campaign stuff too (which is what I’m still using to play Retribution).

Location shouldn’t be an issue. I have tried with already working custom campaigns and they don’t work, the next map is not loaded, Blizzard has broken it! Why? I don’t know, looks like careless coding to me.

If you ask me, this should never have been removed feature, because WE paid for this as part of the game, how its ALWAYS been part of the game. It came with the title, its STILL in the Battle net app even as a button, and Im sure it wouldnt take much to fix.


As a work around (Also see TomCatFix’s post eatrlier): The following files are missing, and re-adding them from an older install will fix the issue:

The checksums match for my 1.18 datafiles, the older ones probably will also work.

Doesn’t work.

What I have tried:

  • copy/paste regarding .loc files in “StarCraft: Remastered” folder
  • moved campaign into D:\Starcraft\maps
  • moved campaign into Documents/Starcraft/maps

It’s always the same result, after finishing a random map of a custom campaign, you get an immediately return to the campaign selection (Stukov, Artanis, Kerrigan) screen.

1 Like

Oh that was referring to staredit not saving, not the load next level trigger.

I did forward the load level bug since it seems to be editor independent. Cross your fingers!


I’m having this same, Issue I’m using the SCE launched through the launcher. I just spent an hour making a nice map for myself then went to save and… nothing happens. Super depressing. It’s just a simple melee map too, I see no reason for this error.

Is there anything at all I can do to save this file?

SI posted the fix 3 posts earlier. If that doesn’t work, you’re boned. Use SCMDraft.


It really blows that I just spent time in staredit for the save bug to happen. No former version installed either so I’ve got no way to do the only fix. Welp thanks Blizzard please fix your product that worked all the up until you broke it.

1 Like

I noticed StarEdit not saving a couple of months ago. I mentioned it to Blizzard, got no response, but have just come across this thread.

I knew StarEdit inside and out, having made a number of my own missions. Every so often, I would have a look at SCMDraft but there was just too much to try to figure out (I completely gave up with the War3 World Editor, and I can’t even figure out how to lay terrain with the SC2 editor). I’m not a “modder”, I just want to create missions with the sort of triggers that the original game used.

Just today, I find that StarCraft Remastered has yet another patch. I didn’t think there was anything wrong with the last one, and from the patch notes, there wasn’t… BUT:

  • StarEdit is now no longer a link on Battlenet (in response to Zeoinx).
  • SCMDraft 2 is now giving me errors when I load it.

So, not only have Blizzard managed to break a really good editor (StarEdit), they have also broken the editor they are sending everyone to.

Awesome job…

I just wasted 4 Hours making a map just to realise that I cant save it, because Blizzard broke their editor. Thanks Blizzard.

Why? it’s been part of the game since it came out in the 90s. I would like to have blizzard improved upon it in Remastered like publishing our maps the same way as sc2’s but I guess they are just going to remove it instead.

When I use ScmDraft2 and make changes to a card and then come in to play when the game starts, does it update and everything I change disappears?

I’m sorry I understand you are not shipping it, I don’t understand the logic behind it do :)) why in gods name would you do that first of all, ScmDraft 2 is buggy as hell, it does not load many maps normally, it also if you say you really supporting this 2nd party app why would you not have a link to ScmDraft 2 map editor in the game where it was for decades, this is doggy move. And I have feeling this has something to do with new lame EULA blizzard has ruled out. Anyway, please put map editor, i see no actual good reason why it shouldn’t remain in the game.

So please, bring it back.

[Edited by Blizzard] This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.