[Main Thread] Mac OS - Can't Connect to Battle.net & other issues after 1.23.5 update

I have the exact same problem

MacBook Pro 13" (2011 Late)
Mac OS High Sierra 10.13.6
Intel Core i5 Dual-Core 2,4 Ghz
8 GB DDR3 RAM

So, to narrow things down, I already tried to uninstall and reinstall both Starcraft and the Battle.net app. I did a reset on my router, and did a software update on it. Released and renewed my IP and DNS to resolve any network conflicts. Still not working.

iMac (Retina 5K, 27-inch, Late 2015)
OS High Sierra 10.13.6
3.3 GHz Intel Core i5
16 GB 1867 MHz DDR3
AMD Radeon R9 M395 2048 MB

11 days Blizzard… this is ridiculous… fix the issue for MAC users or refund the $

3 Likes

Thank you for the reports and requested details! Our team has been able to replicate the issue on High Sierra (10.13.6), they are continuing to look into this matter as quickly as possible to find a resolution to the issue.

If you are on an older version of MacOS (10.12 - Sierra, 10.11 - El Captain, 10.10 - Yosemite, etc), these operating systems are not officially supported as they are below the minimum requirement for Starcraft.

1 Like

Caterpepi, thanks for the update. According to most people who have used it, Catalina OS sucks so I hope you will be supporting 10.13.6 until the Catalina OS is up to par and stable from MAC. Is there a time frame you are expecting to have this glitch worked out?

1 Like

May have found a solution, or one that at least works for me.
Battle.net App - Starcraft menu - Options - Reveal in finder
Double click Starcraft Launcher and then hit Play on the Battle.net App.

Ive tried it three times and its worked for me. Let me know if this solution works for anybody else.

1 Like

Where is the starcraft menu, I do not have that one

7-11-2020 at 8:41 PM - PDT

@Mephisto,

When I Launch the Battle.net App, I find NO StarCraft Menu to get to ‘Options’, to subsequently get to ‘Reveal In Finder’. (8:57 PM - [EDIT:] Just found the ‘Options’ --> ‘Reveal in Finder’ that you mention… Takes me to where I state below.)

As to the StarCraft Launcher, (separate from Battle.net App), for me is found in my Secondary Hard Drive labelled ‘Games’ - (HFS+ Format), then StarCraft Folder, then ‘StarCraft Launcher.app’ which is Labelled with a Silver Text Style “SC”. This FORMERLY had the Silver Wraith Icon in 1.16.1, (or sometimes a Red Wraith), and is now ‘supposed’ to be moot due to the Battle.net App Games’ Launcher.

Now, IF this is where you are taking us, YES, I have seen reports of others, (in the past), that STILL CAN Launch SC:R from this Launcher App.

IF this is where you are taking us, then with my description, above, others MAY now be able to find this Launcher App easier on their own Systems. So, from here, and following your Directions, we Double Click this StarCraft Launcher.app AND then hit Play on the Battle.net Games’ App Launcher. (Seems redundant, but anything at this point is possible.) I’m glad this works for you. Maybe it will work for others.

Good Luck everyone.

TimeLord04

1 Like

I have the same problem! High Sierra 10.13.6 MBP Early 2011.
Blizzard come on!!!

Instead of “quickly” and still looking you should not ruin the game with a patch that instead of work better ruin thousand of peoples computers.

Understand that due to compliance requirements, Bliz was obligated to implement the API updates as soon as they could.

They held a PTR for it in attempt to expose what issues they could, but that was (and always is) limited to the number of participants and what they find report worthy.

2 Likes

iMac 27’’ mid-2010
MacOS High Sierra 10.13.6
2.8 GhZ Intel i5
16GB 1333 MHz DDR3
AMD Radeon HD 5750 1GB

I cannot upgrade to 10.14 as this is the end of the upgrade options for me.
Hopefully, you don’t cut off us High Sierra users…

1 Like

Could you give us an estimated date so you don’t keep us hoping or waiting in vain? Thank you.

Many players like me played SC many years ago, and honestly limiting your access in this way by monopolizing products is a joke to everyone, you can play perfect (it’s part of the beauty of SC you don’t need much to play a real game), I hope blizzard don’t forget us.

7-14-2020 at 7:59 PM - PDT

I HATE being the bearer of BAD News, BUT IT’S HIGHLY likely that by June of NEXT year that High Sierra gets EOL-ed by Blizzard.

This IS due to the FACT that Big Sur is ALREADY in Developer Platform Beta 2 AND will be released at EITHER 10.16.0 OR at 11.0.0, (they CANNOT seem to make up their minds at Apple yet as to the Version Number), AND this WILL force Blizzard to EOL High Sierra.

The CONFUSION on Version Numbers on Big Sur come from the FACT that the Installer says 10.16.0 BUT once you get to the Desktop and hit “About This Mac” it states “11”.

Regardless of the Version Number of Big Sur, the FACT that it WILL release AS EARLY as September DOOMS High Sierra by Blizzards’ own standards of ONLY keeping the THREE most current OSes on MacOS.

I FULLY anticipate that by June of next year that High Sierra WILL be EOL by Blizzard.

I, myself, MUST get the funds to Upgrade my GPU from an NVIDIA GTX-970 4GB Card to the MacVidCards’ AMD/ATI Radeon Sapphire Pulse RX-580 8GB Card, (the ONLY Card I can afford), by March to get my System UP to Mojave and give me one more year of playing SC:R.

Good Luck everyone.

TimeLord04

I’m not an employee so I’m not privy to the internal workings. The SFAs (blue posters) are the only ones who would have that info if it’s available. Sorry! :frowning:

1 Like

Caterpepi, could you give us a approximately date of when this going to be fix. Because this is as you imagine annoying and unnecessary wait if Blizzard wouldn’t have ruin the previous patch. Thank you,

The reveal in finder trick is also working for me!!!

7-15-2020 at 4:51 PM - PDT

New Patch Released:

“Fixes Non-Metal Supporting Macs to use OpenGL.”, from Matt Sherman.

[Full Quote:]

"We’ve just released Hotfix Patch 1.23.5.8607 which addresses the following:

Additional crash fixes
macOS systems that do not support Metal, will fall back to OpenGL", Matt Sherman.

Good Luck everyone.

TimeLord04