Cant Join Any SCR Game, and Cant Submit Ticket

I cant connect to any game, not on nor lan. I have tried reinstalling SCR, disabling my firewall and antivirus programs, and attempting to connect on my friends wifi instead of my own (where his computer works), as well as trying ethernet. I have tried all different regions, and making sure that all my networks are set to private.

It gets stuck on “Downloading 0kb” and then says “Unable to join game”
Every single time.

I’m on a Razer Blade Advanced 15, i7-11800H, RTX 3080, Windows 10 (latest), launching through the launcher.

I’m trying to submit a ticket to blizzard, but every time I click submit it tells me
“You can’t submit this ticket.
An error has occurred. This may be a temporary error, so please try again later.”

This is my favorite game of all time so any debugging steps would be great.

The box to type in the email/passcode doesnt ever come up anymore. Instead some BS app comes up to press an “update” button. The “update” begins a scan & then after a few mintues it doesnt present a play button, it just repeats the bloody thing over & over again. Theres no tech support & Ive had no solution here nor from Blizzard. Its been this way since june. Even though the company is fighting some exceedingly stupid lawsuit you would think SOMEBODY, anybody could solve this? Bloody unbelievable.

Hey there,

Lets try using the Windows Network Reset option. It might also be good to run a malware scan on the PC just in case anything is interfering with the process. Similarly, once we’re sure the PC is uninfected, try disabling any installed security software temporarily.

These steps should help address both the connection to SCR games and submitting the ticket. I do sincerely hope the info helps. Let us know how things go.

Prior to the previous update (early June), everything worked just fine. My system isnt infected. The issue is on your end. Why dont you remove the previous bloody update? Thats the cause of the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.