Problem with old replays

I have a problem with restoring some replays from 3.16, 3.17, 4.2.0, 4.2.1. “All data must be full downloaded to watch this version of the game” to see when I try to run this replay.

No matter if I am logged in or not, I have cleaned SC2 cache from TMP and Download folder. Ive cleaned C: / PragramData / BattleNet. I also went to the folder in Program Files. I tried to repair game installations. I have removed previous versions of the game from the SC2 / Versions folder and am not able to get these replays to play.

Earlier I also had problems with it but logging in solved the problem and when loading the map something was downloading.

How am I supposed to deal with it? How to check how much is missing, it is only a few dozen kilobytes?

This is normal when watching old replays, you need to be online and in game, dont open them from desktop. It should tell u that its needed to logout when opening the replay, just press ok and it will do it automaticly and start to download the files needed by itself, then it will start. Its around 100mb, but sometimes is really slow for some reason. A problem I had during this is that it locks out in a black screen but it solves by clicking in the dark screen. Its buggy.

Do not understand. I have downloaded files and these versions of the game unpack normally. Map cache is also downloadable. You click on “to view this replay game will be disconnected from BattleNet” and then this message pops up that I do not have all the data downloaded. The problem is that there is a little bit missing that won’t download. Logging in a few times earlier probably helped download a few kilobytes. For example, patch 3.16 I can watch the reolays with other commanders on the given map and Raynor cannot give because he is missing something there.

As for errors, you are right offline version is a mistake. When you try to switch to another version of the game, you have to click on the black screen, the problem is that at this point the game often crashes and suggests closing the game or waiting for the game to respond.

The same is true for a small window like when the game starts when the blue bar flies left to right. And sometimes it freezes and you have to close this window so that the game can move on.

Could be a server issue or some specific conflict with your computer. Try uploading the problematic replay to and send it to support.

I already know what the problem is. UpdateAgent.exe must be running, BattleNet applications may be closed. For a long time I was bypassing the application and logging into the game directly.