I installed SCII in a new computer and now it won't update

So I installed the game and before I can play the game, naturally it has to update. Well it hasn’t budged at all after getting the error message that says:

an error has occurred in the script on this page.

Line: 0
Char: 0
Error: Script error.
Code: 0
URL: https : / / navbar . blizzard . com / static / v1 / nav . js

Do you want to continue running scripts on this page?

and it sends me the same error message just with different URLs and it hasn’t updated still. I say yes to all of them, I tried saying no to all of them and nothing happens. What’s wrong?

Howdy Johny85,

Based on what you described, I would suggest that you make sure you are using the Blizzard app to install the game. If you installed using a CD, then the update may not work and you may need to uninstall that version. If you still get these errors, try running the Blizzard app as Admin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.