How to fix Editor scaling in Windows 10, I think

I think I just fixed a problem with the editor scaling, but I’m not 100% sure why it works. FWIW, I have a 4K monitor for my laptop sometimes; that might be part of the problem.

THE PROBLEM:

A lot of my tools were on top of each other, but generally everything was still usable, just slightly unattractive. But the Publish Document dialog box (File, Publish…, Next) has the errors list (lower half of the dialog) covering up the Unlocked radio button.

THE FIX:

  • Find the file. For me it’s at [StarCraft II home]\Support64\SC2Editor_x64.exe.

  • Right-Click, choose “Properties”

  • Choose the “Compatability” tab on top

  • “Change high DPI settings” near the bottom

  • Check “Override high DPI scaling behavior.”

  • Choose either “System” or “System (Enhanced)”

I hope this help someone else!!!

Im having the same issues with 4k. The steps above didnt work for me. I tried System (Enhanced) and System. Both failed. Then ran the troubleshooter for “StarCraft II Editor_x64.exe” and it set my settings to use Windows 8. Check the box under “Compatibility mode” that says “Run the program in Compatibility mode for:” and set it to Windows 8. That wasn’t enough though.
Right-Clicking on my project file “.SC2Map” and in property settings, it was set to open with “SC2 Edit” and I changed it to use “StarCraft II Editor_x64.exe” which can be found in this folder here: C:\Program Files (x86)\StarCraft II
UI looks nicer than ever.