[Editor] Bugs June 2021

Bug list (by Wonder Rem)

If you are of Blizzard’s team, attempting to read my post, please know how thankful I am for you to be here, as this information should be strongly considered as genuine. These are tested bugs, not misunderstood functionalities resulting from my own lack of knowledge (hopefully). I used this editor for the past 4-5 years, and I made my way across on my own, learning from testing things. I also am second contributor to the Sc2 Mapster wiki.

  1. Update 5.0 Build ability now has the Smart flag. Ok, where now?

  2. [Solved] Ability cooldown event (actor events). Patch note 5.0.0 simply never explained register ability charge/cooldown, so the lack of information on the patch note caused to not clarify why the actor events were changed to be dependent of these fields. I left the information here, because the functionalities changed without any warning, which left most of us in oblivion when trying to understand why they wouldn’t work anymore. Frustrating failure about your patch notes which lack essential information for modders.

  3. Unit Compare Kill Count Validator Fixed by patch 5.0.3, thank you.

  4. Referencing Duration Random Maximum/Minimum from a buff behavior have inverted text. For example, I want to use data reference from Duration Random Maximum, the text will appear as: <.d ref=“Behavior,SJHyperionRegen,DurationRandomMin”/>

  5. Unit Type Validator cannot validate types Tech Alias of units. It is unable to use see the value on other units. Same goes for requirements unable to see Alias Completed at unit. For example, a requirement cannot see Alias_Barracks completed at unit on a flying barracks. Do not confuse the Completed vs Completed at Unit on this. My bug is exclusively based on “Completed at Unit”.

Other Validators: Same goes for “Unit Order Queue” which cannot trace either ability class, either ability alias related to training, building, Warp Train, Magazine, Research abilities. Now you’re gonna say it’s the queueable ability or queue? Cannot even find it. Summary, it cannot find Generic, Effect, Queue, Queuable, Train, Warp Train, Train, Magazine abilities.

  1. The “cannot die” flag on buff behavior can be outpassed by certain means. In some situations, even a death remove cannot override it. See the Buff behavior page for more info (Sc2 Mapsters).

One easy example on how to “bug it” is to create a behavior with cannot die flag, and have the field Validator (Remove) : Target Life > 1. Naturally, the buff gets out at one hp, effect resulting from the cannot die blocking the damage, however, try killing this unit over again, you won’t be able to (even if the buff is totally gone). The only way to solve this, is to heal that 1 hp to a greater value, unblocking the glitch. An interesting test shown that using a modify unit effect right after that sets vital to 1 unglitches this bug, as if the number 1 isn’t the same value as the one given by the Cannot Die effect.

  1. A strange bug discovered with the Oracle. Casting reveal on the primary starting structure creates a duplicated model animation actor on the caster, even tho it is not carrying the behavior (which is on events as “Behavior On/Create”). I found the exact location of this bug on the target filters of the search effect, the Invulnerable one. If set to allowed, the bug occurs. To reproduce, one must set filters to allow friendly search, used on an effect-target ability. I tried some other abilities, I couldn’t reproduce it. Also, it seems to only affect the first structure of the game. Killing this Nexus/Command Center/Hatchery and replacing it by another one will not create the bug.

  2. I am currently stucked with a modified “SYSTEM_ActorConfig” Actor, that is forever edited (green), unable to reset it because I dared adding a Custom Death Priority and deleting it. Actually, I couldn’t do it from the table view, I had to force delete it from removing the line in the XML view. Now, the field is grey, but each time I try reseting the field or the actor itself = big crash.

  3. Reported and tested by @Biometrix#9544 / Alien#6946: Add Base Multiply doesn’t work on damage amount fields (upgrades).

  4. Some test made on the Sentry’s Guardian Shield model’s actor seems to show that making the Create Persistent Effect that holds it “Persist Until Destroy” or using the model for anything else that is longer than ~60 seconds seems to have the model disappear on its own. We created alternate actors and models, which worked in some cases, but other bubble models seems to freeze their animation, even if they’re in complete animation bracket start non-stop. This irrational bug also indicates that there seems to be hardcoded errors about these actors/models.

  5. Action Actor Launch Asset/Impact map have a “Scale” option that just DOES NOT work. The only method we have to change a scale, is once again to spam/create more Generic Attack Launch/Impact Actors (Launch Model/Impact Model), that we attach on the action actor with a modified scale. Once again, why could we not spam less files, just for an option that is broken?

  6. Modify unit effect’s cost field (that modifies cooldowns) cannot modify an [Arm Magazine] ability cooldown and [Behavior] abilities cooldowns. The process simply ignores the task.

  7. Since patch 5.0.0, requierements checking for a behavior completed or completed at unit are no longer limited to behaviors being disabled. So, for example, if a unit has a behavior but that behavior is disabled, it is considered true by the requirement.

  8. The new effect, [Last Target] gather type does not work properly, cannot trace any harvest ability what so ever.

  9. “Self” as a required filter on a search effect does not filters well. It takes every possible target anyway. Using the “Include” while negating all filters does not work as a work around either. The only method I found to outpass this broken feature is have the result of the search lead to an effect with a validator “Target Is Self” unit filter with the self required.

  10. Specialize ability cooldowns are ignored if the location is set to “Ability”. In other cases, it is ignored if the flag Transient is enabled. There is a terrible set up interaction between the fact that the ability is passive, having to put a queuable ability or not. It is very unclear.

Also, there is a bug related to auto-cast and stunning. If stunned, the auto-cast still keeps cast/spamming the effect, stacking the cooldown time used (for ex, if there’s a cooldown of 1, it will spam over 25-30 times if the stun lasts ~2-3 seconds.).

  1. Ability Train: Kill On Complete is hardly traceable by actor events, and not even by Spawn behaviors that kill their spawns on spawner’s death. The main problem here, taking a Larva for example, is that on the Egg’s death, the train ability would seem to expect a death event from the Larva. But since we changed actor here, the dying unit that gives birth has its track lost by the training ability that cannot make an event based on its death. It is the very reason why devs came up with the “Create EggsplosionGeneric”. It still is considred as broken to me.
    There is also another problematic with debuffs. When a debuff is applied to an egg, it does not transfer to the newer unit, because it is considered as a duplicate unit created off a dead unit. It would make sense to have behaviors follow up, the same way transfer behavior does for non-innate behaviors.

  2. Annoying requirement glitch: When you change a number on a constant, if you dare not to click it twice, selecting another line (example: Upgrade Count) resets the new field that is clicked.

  3. Vital accumulator used on “Target” location seems to still modify “UI” value of the caster’s weapon “display damage effect” field ( that effect is influenced by the accumulator) if the caster has its vital conditions modified. Example: My High Templar’s weapon damage effect used an vital accumulator that has a ratio 5 “Add” “relative” damage amount with Calculate missing enabled, based on shields vital type, oriented at “target” location (so the target of the effect). This causes my High Templar do deal 5 extra damage when the target’s shield is at its lowest. Yet the damage dealt works fine, the numbers add up, but when I take down the shield of my high Templar (the owner of the weapon), its weapon shows an increase of weapon damage +5, which is false, but only visually (the real damage dealt isn’t influenced). Yet, the caster’s shield shouldn’t modify the display, since the accumulator only validates the “target” location of the weapon, not the caster.

  4. Data referencing a behavior (buff mostly) cost: cooldown time use (or any other cooldown source on it) is not able to trace that amount. In fact, even your devs seems to already know about that issue and never fixed it. We can see that they built a work around concerning the Immortal’s Barrier cooldown by building a dummy ability from which the cooldown is data referenced, instead of the relevant behavior that controls the Barrier timer. It’s simple actually, the Passive button for the Immortal barrier cannot reference the REAL cooldown source, which the behavior itself.

  5. Since patch 5.0.0 or 5.0.3 (I’m not sure), the “Walk Animation Speed” field on unit type actors no longer takes effect. Edit it appears to only affect certain custom models, and some models that belong to Blizzard ex: The Splittering.

  6. Updating (or simply setting) the “Fraction” field on a damage does not update the numeric value on the weapon’s UI, although the damage is updated.

  7. Unit Compare behavior can fail a simple task, discovered in a specific circumstance. Use an Effect-Target ability, and on the first effect, set a Create Persistent Effect or a Set Effect from which the location is target unit. Good so far. Now set a validator on that Create Persistent/Set first effect (Unit Compare Behavior Count that requires a X behavior on the caster), which stipulates that the caster must have X behavior greater than 0. Works so far. Now, still on the same validator, set that the Required caster of the behavior must be the target. FAILURE. I ran a situation in which the target was clearly the owner of the X behavior, and not only the ability could not aim at anything, it gave an error before I could even choose a target. Same faillure goes for Unit is Tracked Validator. Yes, I know, the failure seems to be that the validator is looking for the target that has not been targeted yet, which conflicts the ability, I get that. It is however, not rational, or proove me wrong, this is not the way that this validator is supposed to operate.

  8. Cooldown time start for charges does not work on train, warp train abilities (the only 2 I tested yet), not until I set the location to something else than ability. The cooldown we put in there is simply “ignored”.

  9. Upgrades Cannot create a chance on behaviors (mainly buff behaviors as it is a popular request). For example, if a buff behavior has 0% chance on its damage response, and the modder wishes to activate the chance field by setting it to 1 with an upgrade, the behavior will never adjust, thus staying frozen at 0 chance to give any damage response. It only works if there was a tiny bit % of chance (the editor consideres the field as valid by then), but at 0, it seems that the behaviors consideres it as shutted down permanently. Of course, there is work around that makes the behavior all set on the unit and then only prevented by the requirement, but what of it? Why is the modder to be limited by this kind of restriction? This is another stubborn functionality of the editor that can only be known and told by veterans who identified this problem in the past.

  10. I made a Morph Ability, which I needed it in my unit’s actor as an event to apply that unit its Group Animation B. I was never able to trigger the action in the events with the Msg Type: Ability Morph. I had to use the Msg type Ability instead. Sadly, this gives less option (as I cannot use the Cancel Event) and doesn’t justify why a more morph specialized event cannot cover its own morph ability to execute the action. Take note that I did not use terms such as Morph From or Morph to. I used the ability directly in the source name.

That being said, it seems that any CActorModel, Sound actors etc, Model Styleoneshot and on and on have a terrible interaction with Morph abilities. They cannot trace any ability morph event. They can trace them however if used with a MSG type “Ability” event subname “Start”, but cannot trace the subname “Stop” part when triggered.

  1. On Modify Unit effects: It appears that the “Copy” Flag from the Modify Flags field works, but in an inverted way. For instance, a Launch Location is where the information is copied from, sent to the Impact Location , which is the unit that should copy life, veterancy, kills, etc. A test has shown that those 2 locations invert the result: the Impact Location sends its information to the Launch Unit, and so, the launch unit gets to copy the Impact location. Careful though, this only concern the copy flag. All the other fields of the effect work well with the Launch/Impact logic, yet.

  2. Action Actors refuse any other effect than “Damage” effect in its “Attack Token” or if there are no damage effect in the child effects. This doesn’t seem to reflect the full ramification of what the action actor can do. But let’s pretend I obey to the rule, strict by the editor: My weapon’s first effect is an apply behavior. This apply behavior effect is the Attack Token of my action actor. Then, the only way my action actor will accept it as valid, is if the behavior has a Damage effect in its periodic/initial/refresh effect. Otherwise it is refused. How logic is it that the expire effect is not accounted for it? I mean, I could put it in a periodic effect that sets off .01 second before the expiration, it would do the same. Also, in case I wanna make a work around, I could make a dummy damage effect. But then, I just failed to improve the editor’s functionalities by avoiding to tell you guys about the bug, and I just spam more effects, a more massive file. We’re talking performance here!

  3. Your new field on upgrades: EDSTR_FIELDNAME_CUpgrade_LevelButton: I dont need a functionality that changes the button AFTER the upgrade is complete!? The upgrade already does that (ok perhaps not the upgrade’s “Button”, but how useless is this?). In fact, it only changes the button interface in the queue, not the button on the command board. Is it meant to be trivial as such, or do we have a broken feature right here?

EDSTR_FIELDNAME_CUpgrade_LevelRequirements: Works partially. After testing it, I would presume requirements to still be better than using this. Thinking I want to block an upgrade’s max level for example, I could use an impossible dummy requirement (that avoids creating a ton of data), but this doesn’t work as expected. We cannot queue the last level of upgrade, not unless the first levels are completed, IF the requirement inserted in this field contains a blockade for the USE part that has nothing to do with the upgrade in itself. So there again, what’s the point of having this field, if It’s safer, better to use requirements? For sake, I can even change a requirement upon an upgrade.

  1. I used a DeadAnimationRemoveMacro for units witha death time during enough time. Works so far, I could put events in it, but it doesn’t work with death by blast, even if the Death Effect is all set up to be ignored on the blast section. This is not normal, or even logical. In fact I ran a test. I made it create an animation to see. The DeadAnimation macro did perceive a death by blast, but then, not able to use events based on a timer within my macro. AND yes, my unit’s death time covers it all, I understand enough of those strict untold mechanics.

  2. Any wander behaviors prevent those units from triggering the “Impact Effect” of a Launch Missile effect, when launched. For example, use a launch effect that throws a larva, you will never be able to trigger the Impact effect of the effect. To be fair, this was in a particular order of effects. I tested other situations in which a unit with a Wander behavior doesn’t bug the impact, so I’ll leave it to you guys to contact me if you want to know how I built this bug.

  3. On validators, using the Result-Failure “OK” makes the validator ignored by anything. Also, leaving it to default “Error” while having a custom text negates that custom text, “Not Supported” leaves no message and nullifies the ability completly, replacing it by a move effect in some cases. Also, choosing a custom sound cannot be done in Table View, but only detailed view.

  4. On Actor Events, Effect Events using a Launch Missile effect cannot properly identify the “Impact” Sub name moment in the occurance of the impact. It fails and launches the event at the very start of the Launch Missile effect that is mentionned. What’s the point of having “Start” Sub Name if “Impact” just ends up being the same.

  5. The mechanics for attempting to change a unit’s Turret for another, disabling the old one, is a terrible set up on your side. The limitations to what we can do forces us to morph the unit to another, but yet again, this leads to many other limitations (trust me, I’ll give you the list of what). I can’t even think of using a buff behavior, they dont work properly to change the turret and it’s not possible by uppgrades either. It is clearly a bug, because if in fact we cannot put 2 different turrets on a single unit, what is the purpose of a Modify Unit effects that can modify a specified turret ? Pointless, because units cannot handle 2 turrets. Please allow us to to be able to set up turrets on units as we want.

  6. Unknown if it’s intended: Removing a behavior with “Remove Behavior” effect, based on it’s tech alias also removes the child behaviors created by that behavior, even if they do not own the specified tech alias.

  7. Ability Morph’s Automatic Unmorph does not work without Automatic being enabled. This is a huge problematic for underground turrets, which cannot use the unmorph coponent and an auto-cast at the same time. Contact me for more details on how to cause it.

  8. When inserting validators in the info array of a build ability, using copy / paste to add others sometimes bug the Info Validator array and replaces them by “None” when leaving the menu.

  9. On unit data, “Energy Regeneration Delay” said to be a delay between energy uses doesn’t work. You use energy from an ability and the energy still flows.

  10. Validator “Unit Order”. Attempting to idenfity the auto-cast state of an ability (Set Auto-Cast + Set Auto-Cast On) causes an inverted result. If “Set Auto-Cast” is used only, the validator only checks that the auto-cast is on, which is false. The purpose of “Set Auto-Cast On” is to indicate that it is activated.

  11. The combinaison of a Morph Placement with an unmorph array causes an unwanted bug, causing the unmorph unit to be unable to use any form of move ability. To reproduce this bug, it is essential to produce the “Morphed” unit first, and attempt to unmorph it (which doesn’t offer the placement function). The process will work, but keep suppressing movement. Producing the moving unit the other way around doesn’t cause this bug.

There is also another bug with Morph / Morph Placement. If a unit that can use it, and the resulting unit has “acceleration” more than 0 (and 0 speed btw), this will cause a glitch that allows the unit (morphed one) to gain movement speed equivalent of the previous version of unit. The newer unit that shouldn’t be able to move. I tested it, it happens on Siege Tank Sieged, and only if the morph ability has been used. Using a created Siege Tank Siege does not trigger the bug. The UI also reveals something, that once morphed into the Siege Mode, it has 0+ 2.7 movement speed (the equivalent speed of unsieged). The source seems to be a conflict between the 2 units. More precise testings on siege tanks have shown that: In any morph abilities, if the Collision delay isn’t 0,1 greater than the value of the Mover delay (we don’t talk about durations), this causes the immobile unit to gain movement speed from acceleration values. There seem to be a conflict between collision and mover values, but this can’t reproduced on every unit. Yet, this is a good indication of where to look at.

  1. Adding Acceleration Bonus on a unit, from a buff behavior, returns null if the unit has 0 acceleration as default. Why should it be fair to be able to add movement speed to a unit with 0, but not acceleration? In that case, the only way we can add acceleration on a unit is to have it innate or change the whole catalog for only one unit that’s affected by a buff.

  2. Adding an “Attack” ability from triggers works, but doesn’t sync with actual weapons on the unit (whether the weapon was innate or from a behavior). The only way a weapon responds to an attack ability, is if that attack ability was innate. That’s not logical from a system that’s supposed to give us the privilege to add or remove abilities but to use them.

  3. When setting an effect array in “upgrades”, it is impossible to use the search box if the editor is set on Table View. The box simply does nothing.

  4. Unit affected by Load Container effect toward a Magazine cannot be released from a Release Magazine effect.

  5. Accumulators don’t work on Attack Modifier behaviors. I tried putting one in the damage scaled section, it never worked. While I’m there, I’ll specify another bug related to Attack Modifiers. If it leads to an add behavior with a buff that has a periodic dot, the dot does exactly the same triggering weapon’s damage for no reason. It is also possible to reproduce this bug with a User Data Effect. Since I have non-existant feedback from Blizzard, I will describe this bug on demand.

Also not working on Additive Attack Speed Factor field from Buff Behaviors.

  1. Attack Modifier Behavior: I have a SIMPLE validator on my Attack Modifier Behavior: Caster is air (Unit Filters for caster, Air Required). The Attack Modifier still outpasses it. It’s like if this kind of buff cannot properly trace any reference oriented to the caster.

  2. Retarget features on Launch Missile effects are very limited. The rules that ensure the retarget success are lacking big time. And since I do the work for you guys, here are the rules that I’ve analysed:

  • The target filters can only aim for enemies, and will do it anyway: unchecking enemy doesn’t do anything (not even prevent the retarget from working), and the retarget feature will only work in the case of a nearby enemy, even if player is allowed.
  • The target filters must match with the using weapon exclusions/requirements. For example, a missile turret’s attack cannot retarget a ground target. Since the previous point shown that some filters are ignored (a bug), it is unclear to say which filters are relevant to use. To be sure, one should exclude dead, hidden, invulnerable, missile, stasis.
  • The validator on the Launch Missile effect is checked when attempting to retarget.
  • For unknown reasons, it doesn’t work on Effect-Target abilities. They are simply not supported by this feature.
  • At some point of the missile’s arrival, it may sometimes fail.
  1. Damage response on buff behavior do not prevent area damage from damage effects. How useless is that.

  2. Upgrades cannot Add/Substract/Multiply/Divide/Etc. numeric values to actor’s scale. You can only “set” them. Lack of content usage.

  3. Buff Flag “Disable During Construction” on Buff behaviors is a weak flag. By that, I mean that for the instance of a moment at the construction stage, the behavior becomes on and then shuts off. Of course, it’s easy, we can use the Construction filter in its validators, but why? Why is this flag unable to do its job properly? This is a major inconveniance, especially when setting actor events based on that behavior.

  4. Upgrades can change a range actor’s range value work, but does not properly effectuate the change on Placement Actor using this range actor. For example, if you upgrade the range of the Sensor Tower Radar range actor and you attempt to place the structure for building it, the placement actor of it cannot seem to link to the newest range value, keeping the old one as a frozen reference.

  5. Increasing “Progress” rate in buff behavior works well for speeding the build time, but it screws with progress actors, who are unable to track the actual build time, thus creating animation distortions. (ex: a building that ends up with Build D Start will never be able to play that animation, because the constructer built too fast).

  6. Actor Model on Custom Death Fields (CActorUnit) are useless. Whatever you put there, these fields are simply ignored by the editor.

  7. Requirements “Show” part can stop an ability from channelling, which is not normal nor the purpose of “Show”. Only “Use” has that purpose. To reproduce this bug, have an Effect-Instant ability cast a channelled Create Persistent effect, with an initial Add behavior effect that adds Behavior X. Now, in the requirements of the ability, have the only the “Show” Part return false if the behavior is equal to 1 (count behavior at unit works as well since the behavior wasn’t innate), and you will notice that the ability is interrupted.

  8. Resource Behaviors can’t be disabled by requirements. The requirement is totally ignored.

  9. Chaning data ID cancels out the Prefix/Suffix change when pressing ok. You always have to open it up again to make sure the Prefix/Suffix is properly changed.

  10. Level Gain / Loss effect on veterancy behaviors does nothing. No effect is executed at those point moments.

  11. On unit UI data, “Detector” conflicts with Subtitle location.

  12. Modify unit effects “Experience” Field does not change the experience on the unit. It oddly triggers behavior level events, but the experience remained unchanged.

  13. Set Text (Localised) action in actor is unable to save any custom text. Only the Text Keys remains when clicking ok.

  14. Removing an icon from import list and saving causes any instance using it to present an error message saying that X file is missing. Good so far, but if you intend to put it back in the imports, yes the icon will work in game, but the miniature image on the editor remains glitched forever, unless you rename and pick a new file as an icon.

3 Likes

Another big issue is the fact push priority doesn’t even work properly, lower priority hold positioned units can still be pushed but your unit preemptively starts pathing around, and if you spam click to go through the order gets cancelled very quickly.

I’m not sure for the first lower priority part. Do you mean that lower priorities units should be excluded from being pushed if they hold position?

For the second part, I need some help to reproduce it. Can you give me a particular situation/terrain, in which I could see how it is broken?

Surround an Odin with units and make them all hold position, it’s possible for the Odin to move through but it’s incredibly faulty, the Odin should be able to walk through units seamlessly regardless of hold position.

I’ve tested it, when the units odin is inside a tons of scv around, and you order it to path outside the hold positioned scvs, he goes smoothly. If you however order Odin to go through them when he’s outside, and he could path elsewhere, I think Odin is conflicted between the order and the will to path elsewhere around the holding position scvs. I think you are right that this is a bug, but im not entirely sure how hold position behaves, I lack the knowledge on this.