Compiled 10th Anniversary Achievements Tips / Issues / Bugs

The achievement for The Evacuation mission (WoL) is also bugged. It’s called the Great Purge and requires you to destroy all Zerg structures, but is in fact given only after completing the mission, not after destroying the bases.

1 Like

Confirmed working with this setup. I used “Repair Beam” before - could be the source of problems.

As of right now, the only achievement I’m missing is “Contract Saviors”. Hope it gets fixed soon.

1 Like

Thanks. I tried but with Reconstruction Beam and didn’t get it. Maybe I accidentally used an ability.

i just need the moebius now. just got all lotv

How did you do the warpprism one from The Infinite Cycle? Did the mission get fixed?

Details in main post above.

1 Like

@Kyrie, thanks for adding the Into the Void issue to the list, but please take a look at my EDIT in my post; I used fog of war cheat to verify there were NO buildings anymore, also tried to eliminate last enemy units on the map, did not help.

Hmm, the key issue is that I have obtained it, as with other people as well. Your only other option is to restart the mission and try again (preferably also reboot your computer just to eliminate every possible error we can think of).

It is unfortunate but when it comes to technical issues, the most difficult part isn’t solving the problem, but finding out what the problem is.

Thanks haha, though I just thought I’d focus on purely the 10th Anniversary Achievements. It’s good that you listed it here though, so people can read and know as well. :slight_smile:

Hi Ssorg, I too experienced your issue initially, what I did to fix it was to restart the mission and made sure i killed the void rifts before i killed the void shard during the starting part where you only had some army, maybe give this a try and see if it works, the reason being if you killed the shard before any remaining rifts the cutscene will occur and bring you to the second part of the mission which makes any rift you did not kill kind of goes into void, hope this helps. GL hunting

1 Like

WoL Campaign Missions

  • The quick and the dead (activate 2 within 4 minutes)
  • Way of the nerazim (kill/destroy 30 units/buildings)
    are bugged, too. Did both missions two times, no achievement.

This has been addressed in the post already.

There are no issues with this. Remember to kill with Dark Templar as the achievement states.

There is only 1 bugged achievement that will prevent you from obtaining it. The rest are minor bugs with a possible workaround. As mentioned in the post, I have gotten all accomplishments except that 1, so I don’t think there are any major bugs left.

1 Like

This achievement is easily done, since each DT kill is counted when DT only damages the unit or building, even if he’s not the one doing the killing blow.
Therefore, you can just make a protoss deathball with lots of DTs and faceroll through all the enemy bases.

So the first hit is what matters?

PJSalt. That’s going to be a nightmare.
Edit: Just got Warp Incomplete. Now the only one I’m missing is the Moebius Factor achievement.

You might want to add this to the swarm achievements, as a tip:
Bad Blood: Kill 15 enemy units with Parasitic Dominated Terran units in the “Conviction” mission - you need to actually be able to have infestors at this point, so you have to do the Skygeir missions before this one, otherwise you will not be able to do this achievement.
People might want to do the achievements in a different order than the one they are listed in, and in this case it would be really bad to chose Space missions before Skygeir.

Credit for this goes to my friend Cristall, I haven’t played the Hots Campaign yet.

If you do Master Archives instead of New Campaign, then this isn’t an issue. Also, the easiest way to do this is to get all the tanks in the area where you need to defend Kerrigan. Then just siege them up and watch them plow through the next defenses.

I really don’t want to get into an argument here, but… in the words of Dr. House “Good guess, but no!”

Master Archives doesn’t grow in space trees, it just gives you the mission and units in the same order in which you unlocked them. And some older savegames can’t be loaded anymore due to version issues, so if you last played the zerg campaign 2-3 years ago… gl with getting (different) archives.
Edit: Ok, somewhat my bad on the version thing, it seems campaign files are far more “flexible” at being loaded than other types: You can load campaign files from version ~2.0, which was released ~2014, so there’s that. Even so, I’m pretty sure there might be quite a few people out there who played the campaign only once or twice, and it might not have been in the correct order.

Basically every time you play campaign you get a different archive, “archiving” the missions you played IN THE ORDER you played them. So, yeah, if you have a campaign save that isn’t old enough to prevent the game from loading it, and if you played the missions in the right order, than yes, it probably works to do the achivs from there. If, however, in all your archives you did space first and skygeir after, then no, there’s no chance to do this unless you start a new campaign.

The achievement trigger is missing an exclusion for the Xel’Naga Shrines.

As for enemy structures, those can’t be killed by the drill either.


However there’s an issue with this: when killing the bonus structures (not sure about enemy structures), the laser kill counter still shows 0 on the laser, during the mission. However at the end-mission stats, it appears as 3 (or however many you killed).

So I’m guessing there might be a way to distinguish between structures and units, or at least between neutral structures (like the artifact ones are) and enemy ones.

I think there is an issue with the “Disintegration Doctrine” achievement. I’ve completed the mission 5 times clearing all structures, and made sure there were no auto turrets around, but I still have not been awarded the achievement. I have saved and then used TookTheRedPill to see whether or not I missed any structures and there were none. Does the achievement require the player to destroy the structures? I don’t know what else could be happening