Co-op commander progress reset

Logged in to play co-op for the first time in a long time and noticed all my commanders’ levels were reset. Did a reset happen?

Edit: some of them got reset, Raynor, Kerrigan, and Artanis. There are a couple of commanders I don’t remember if I leveled them or not.

Try logging in again, sometimes the authentication process goes a little whacky, but usually reloading will fix the issue.


Yep, I tried that, and I had issues with logging in from a different location, so I also reset my pass. No dice.

Plan B, double check you are on the same region I guess? I know you would probably have already checked that but worth making sure I suppose.

Yep same region: Americas.

Any Blizzard folks able to provide clarity on this issue?

My Co-Op commander progress was reset as well. I have attempted every single suggested fix in the forums, especially all of those suggested by Blizzard. I just absolutely can not get my progress back no matter what I do. I have even given it several days, weeks, to see if perhaps it just straightens itself out on server end with no luck.

I tried region changing, signing in and out, assuring that I am on the correct account, running the game as administrator, reinstalling, and every other suggested fix out there.

Please. Help.

Do you still have the achievements coming from leveling up the reset commanders?
If you do, and they’re below level 5 (because if they were level 5, you might have leveled them when the level limit was temporarily disabled), confirming it would add some weight to the fact it’s indeed a bug.

This happened to me recently and this is how I fixed it… Login was messed up in americas server. Simply swap region to EU server then logout. Swap back to americas and log back in. Fixed it for me. Hope this helps!