Can't load mod in official maps

So, I just started work on an extension mod for Starcraft 2 that is meant to modify the player’s starting setup. It’s meant to work with any 2v2 map, like extension mods do. I managed to get it working exactly the way I wanted to. And got it running on many official maps.

However, there’s a bit of a snag with that. I can add it as a dependency to a map, but in order to actually get it to run, I need to set up a trigger in the map file that references a function in the mod. The trigger doesn’t even have to be enabled, it just has to exist. Without it, the mod just doesn’t load. It’s as if the map loads up, and looks at the dependency list and says, ‘well we’re not actually using this mod, so we’ll just get rid of that.’ I have to trick the map into actually loading it.

This is a major problem, because the whole point is that I should be able to use it on any map from the word go. Other mods seem to work fine without such a trigger, why is mine having such a problem? Is there some setting I’m missing somewhere that’ll force the mod to actually load?

If anyone can offer any insight I would greatly appreciate it.

Well, I solved the problem. I don’t know if anyone else is likely to experience similar issues, but I might as well post how as a follow-up since that tends to be standard practice on help forums. But basically, the solution became obvious when I read the editor tip that popped up today, and it was tip #3, which explained exactly how to do this exact thing… So I feel like a ninny.

Anyway, all I had to do was look up the library ID of the trigger library I created. From the Triggers module, select the library, and from the menu, go to ‘Data > Library > Change Library ID’. Then go to the Data module, look up the ‘Default SC2 Gameplay Settings’ entry, and add my library ID to the ‘Trigger Libraries’ entry.

It’s so simple, and I feel so stupid for missing it. Hopefully, this will prevent others from making the same oversight.