Bnet launcher "install" instead of "play"

Good morning,

I can’t start Sc2 because the bnet launcher wants to install Sc2 although it’s already installed and patched.
I was able to play yesterday but today it doesn’t work.

Edit: Now it’s working again - weird.


I have the exact same problem. Didn’t work yesterday, and it doesn’t work today either.

edit: And now it’s working for me again

Can you post the error code?
I didn’t restart - I only shut down the app with “ctrl alt del” / task manager.
I believe I tried to start the launcher 2 times then Sc2 directly 1 time and then the launcher worked again or something like that.

I also had the described problem. A reboot helped me.
Maybe you try to start game via SC2Switcher.exe.

if it says install, you can click on locate the game and then browse to the folder that it is installed in.

Nope, that didn’t work at all. But now it has fixed it self for me anyway.

Same problem, but after i choose the right folder with “Locate the game” link, i get another error “Whoops! Looks like something broke. We’ll try to fix it, so please try again later.”

This issue also occurs with “Heroes ofthe storm” and Starcraft 1.

Yesterday everything was working correctly.

Diablo 3 and Overwatch seems fine.

Hey all,

There was an issue in the Blizzard app yesterday that caused this, but it should be cleared up now. If you’re still having issues, please try restarting the PC and then re-launch the Blizzard app. It may take a couple of restarts of the Blizzard app for it to pick up the changes.

Yeah - if it doesn’t work, just try it 5 times (and restart the pc 1-2 times) and the problem will solve itself kinda. ^^
It was a really weird bug.

I had the bug and I found a better solution than restarting things blindly : open your Task manager and close the remaining Battle net Agent process after having closed the app, and then it’s good when you run again the app.