An unexpected fatal error occurred. (March 2024)

New $3.2K Alienware R16 gaming PC on windows 11, SCII usually launches fine, but randomly in game or after game it will inevitably crash with “An unexpected fatal error has occurred.” I also tried to play a couple games of Heroes of the Storm and it also crashed mid game.
I’ve spent a lot of time trying to resolve and referring to the posts in the last 5 years.

  • Intel drivers, Windows 11, and NVIDIA drivers are up to date.
  • Issue persists when there are essentially no apps or overlays running
  • OneDrive is confirmed not synching sc2 folder, and has also been uninstalled altogether
  • Uninstalling or Resetting game settings did not work

3/12: 2D0305AA-0362-4006-9BAC-5FBCD0910FD9
3/12: 5458C0AE-B0C6-40CF-A5F1-12F5175D833E
3/12: C59858D1-B374-496B-9C88-0805211B15E7
3/12: A1CF7196-91DE-471C-988D-0C46442A563D

3/15: 7719AB4B-4323-4649-83DC-034F87C586B3
3/17: 713F8C23-3705-43FE-BAA6-1A6B2CE1235F
3/17: 65DE085F-455F-4D3A-92BC-707D162827E2

3/18: 7B638BB3-7952-428C-B54B-ECD4B433C68C
3/18: EE3AC2C7-9885-4ED9-923E-934DCE889590
3/18: B7AACF1C-9957-40A2-80A6-7CB2257E3DD4

I greatly appreciate your help

Same but as for mine, it says that error even after i just started the game and clicked on custom. Apparently it’s their new update that screwed everything up. Even their replays can’t be replayed anymore if it’s a file before the update.

1 Like

Yep, same here. I get the error code D46042A8-974A-4EA2-99A9-A84392D55839 only when going to the “Custom” tab. Can play Campaign fine. Uninstalled and reinstalled and still the same. All drivers up to date. Literally every other game and\or application on this 9 month old PC works fine except SC2. SC2 also worked completely fine up until this last update.

Have to wait for the one, part time intern to fix their stuff up I guess.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.