Your Rendering Device Has Been Lost

Continuation of this thread.

Still crashing on launch of Overwatch, and sometimes in the middle of D3.

Troubleshooting for the “Your Rendering Device Has Been Lost” error can be found here:

If you clicked and looked through the thread you’d see that that thread, along with troubleshooting suggestions, was clearly linked already by a blue post and stated it has no affect on the issue.

Did you try drivers released before September 19, 2018? The newer ones have the 20-series cards included, which was also causing me to have Overwatch crash from the same error. Rolling back to early Sept, I think I did the 9th release, fixed it for me (for now).

I have already tried 397.64 geforce driver and the latest one, both don’t help with the rendering device failed, however prior to getting a new computer this did not happen.

Out of curiosity, did you look in the Windows Event Viewer under Windows system logs and see what’s happening at the time of the crash? This will generally tell you if some piece of hardware has stopped responding by marking it with a red exclamation point. :exclamation:

AppID {D63B10C5-BB46-4990-A94F-E40B9D520160}
AppID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
“The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
to the user MOEPC\Moe SID (S-1-5-21-739281330-2681164236-38601799-1002) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.”

This is a common Windows 10 installation/update error, where you are lacking administrative permissions of specific files/directories and permissions to the registry data. This is not the fault of you or the Overwatch client, it is specifically a Windows problem. You can Google a fix by sticking the error text in Google, or you can look for Windows updates, or roll back to a previous update.