Watch Point Pack

I bought the Watch Point Pack back in June for PS5 through Playstation so I could participate in the beta and get the cool stuff for OW2 launch…But it’s still not applied to my OW2 game. I’ve tried logging out of PSN and restarting the game. I even logged out of Battlenet and restarted… What can I do? :frowning:


I also purchased on PS5 pre release, account merged pre release, and PS5 PSN store is showing I can purchase again?

Have not received anything from it yet (no 2k currency, skins, it’s still locked in-game), and have been in playing as of yesterday.

1 Like

Yep we’ll just have to wait. I’ve noticed this is very common to everyone on ps5. I still don’t have the battlepass and the space raiders skins that I’m supposed to have.


Yup, hoped it would kick in for the 2nd time getting in, Watch Point Pack still not recognized.

Best thing to do is give this some time. I am sure they have experiencing some delays with everyone obtaining the Watchpoint Pack and Battle Pass purchases for PC and console. I bought mine and still waiting for mine as well so we may just need to be patient for a bit longer.


Appreciate that, y’all. I’ll be patient <3

Do we have a status update on the Watch Point Pack I am missing? Maybe my search skills need improved, all I found is this, Overwatch 2 Launch Status Update

doesn’t mention it

Not that I know of and I am sure they are fully aware of the delay. I didn’t see anything on that last update either which wasn’t very reassuring, but I would recommend to maybe give a few more days and if nothing, keep posting on the forums asking for updates.

1 Like

good stuff, thank you

Had a chance to login after the first server maintenance today, and everything from the pack was there :slightly_smiling_face:


Aw, I’m glad for you! Unfortunately, I still don’t have my WP pack content. The OW Twitter did make a post last night saying they are testing a fix for console players who don’t have their WP Pack content. Fingers crossed lol

1 Like

Crap sorry to hear it, I thought it was a fix-all thing.

1 Like

They’ve acknowledged that this is a common issue but haven’t said anything publically just yet.

Their support page acknowledges this is a common issue though.

1 Like

Still nothing for me - frustrating

1 Like

Looks like fix is coming tonight!