Voice Chat Error [3]

I get this error every time I login OW since the WW patch. My game has also started stuttering as a result and makes the game unplayable. Have tried changing audio settings, resetting settings in Bnet app, scan and repair, OW reinstall, nothing fixing it.

Error: imgur com/LZiEGAX

1 Like

I have the same exact issue on this account with the voice chat error 3 that gives me stuttering which makes the game unplayable.

On my other account I don’t have this error so there’s no stuttering at all.

Any fixes?


They are fully aware of this issue and are investigating on it.

Getting same error. When I go to Settings > Audio > Voice Chat Device and hover over it’s shows it switching to and from random devices. This is causing frame drops and micro stutter and the game is actually unplayable.

Link to example: trash devs - YouTube

1 Like

Have confirmed, this issue is indeed based on the bnet account. Error does not occur on my other account. Also, hardware is not the problem as the issue is exactly the same on my other PC’s and laptop.

1 Like

Triple confirming here; this is my second account as well. Forgot to mention in OP. Main account 100% perfect 0 issues.

Yeah, I’ve decided to create trial account for testing this problem (because trial period for OW is avaliable atm) and there’s no voice chat error 3 which means no stuttering at all.

I really don’t know how this bug is affecting only some accounts.

Who knows when this issue will be fixed…


@here - So my issue has been fixed… I’m dumbfounded as to how it happened, so I’ll just tell you exactly what I did and wish you luck.

I reverted my nvidia driver back to 496.13. I also installed the nvida audio driver that came with that build ( I also changed my SLI PhysX configuration from Auto-select to GPU (2).

Loaded back into OW, still got voice chat error [3]. Disappointed the roll back didn’t work, I claimed 11 loot boxes that were gifted to me by a friend. OW client disconnected and sent me back to login. I filled out my login info, then it asked for my authenticator… I’m too lazy for that so I exited the client.

Upon next load in… no voice chat error. Checked sound settings and the game wasn’t swapping between input/output devices any more. Micro stutter gone.

So I have no idea what actually fixed it. That’s just what happened to me. I’m sticking with the old drivers for now and going to thank Krampus Rat for my Christmas blessing.

Good luck fellas, and Merry Christmas!

1 Like

I’ve tried that before, with the previous drivers, but with no success.

I just can’t seem to wrap my head around as to how is this account specific issue/bug?

yeah rip ive had the same issue i reinstalled windows and now ive got this issue lmao

Yeah rip, me too.
no amount of re-installs will fix it. Disconnected the electrical box in the house from the grid and re-installed. Issue remains.

Found some errors in Overwatch.txt in Documents/Overwatch/Logs , I have no idea what they mean though. This is at the start:

[29256] [ERR] [bnl] [External(0)] [External()] [2022-01-02T11:36:42.506Z]: PathOps: [20220102T05:36:42] {2828} ERR: .. is the leading path component: /../.build.info
[29256] [ERR] [bnl] [External(0)] [External()] [2022-01-02T11:36:42.506Z]: PathOps: [20220102T05:36:42] {2828} ERR: path normalization failed: /../.build.info

Resume further on down (tried to all include relevant lines):

[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:50.525Z]: ==[VC] Request login 4dd313e4
[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:50.525Z]: ==[VC] Login credentials requested
[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.061Z]: #=[VC] LoginCredentials 3 3 4dd313e4 811c9dc5 
[29256] [ERR] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.061Z]: ==[VC] Credentials failed 3
[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.061Z]: ==[VC] Request stop
[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.061Z]: ==[VC] Cancel all queued trackers 1
[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.061Z]: #=[VC] Error displayed to user 3
[29256] [ERR] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.076Z]: ==[VC] Force destroy 2
[29256] [ERR] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.076Z]: ==[VC] Stop request failed. Forcing stop state

Resumes again (essentially keeps repeating this part or similar like the one above):

[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.504Z]: #=[VC] LoginCredentials 7 3 4dd313e4 811c9dc5 
[29256] [ERR] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.505Z]: ==[VC] Credentials failed 3
[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.505Z]: ==[VC] Request stop
[29256] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.505Z]: ==[VC] Cancel all queued trackers 3
[29256] [ERR] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.521Z]: ==[VC] Force destroy 8
[29256] [ERR] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.521Z]: ==[VC] Force destroy 9
[29256] [ERR] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.521Z]: ==[VC] Force destroy 2
[29256] [ERR] [VoiceChat] [External(0)] [External()] [2022-01-02T11:36:51.521Z]: ==[VC] Stop request failed. Forcing stop state

Here is a normal login with no errors on my other account (started at relevant lines)

[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:40.990Z]: ==[VC] Request login 67e6eebe
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:40.990Z]: ==[VC] Login credentials requested
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:41.590Z]: #=[VC] LoginCredentials 3 0 67e6eebe ac294d21 7d33d227
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:41.590Z]: ==[VC] Connect requested 080206e9 7d33d227
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:41.924Z]: #=[VC] ResponseConnect 03 0(0:811c9dc5) 080206e9
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:41.941Z]: ==[VC] Login requested 080206e9 9bd5d047 ac294d21 67e6eebe
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:42.057Z]: #=[VC] LoggingIn 00 0(0:811c9dc5) 9bd5d047
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:43.193Z]: #=[VC] ResponseLogin 03 0(0:811c9dc5) 5a769c4c@4a95b6d2
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:43.193Z]: #=[VC] LoggedIn 00 0(0:811c9dc5) 9bd5d047
[25848] [NRM] [VoiceChat] [External(0)] [External()] [2022-01-02T11:53:43.209Z]: ==[VC] Login complete 67e6eebe ac294d21 9bd5d047 

Probably means nothing to anyone but maybe it will help find an answer.

You can also see this happening if you add --console to your additional command lines in your OW launch options.

imgur com/iyrOu01 : vid of console spamming

i got the same problem. When i was in a comp game i just dc and couldnt connect i had to resart my pc. Then i rejoined and played the rest of the match and even won the match and lost 60 sr. Thank you blizzard:(

If your internet is already choppy why join comp

Has there been a fix for anyone? My ticket just got answered telling me that voice chat settings shouldn’t be account-bound, but that’s clearly the case. I have already uninstalled and re-installed the game, and at the behest of CS I cleared the caches in ProgramData/AppData/LocalAppData. After all of those I still get the constant device switching on my account on both my main PC and my old laptop, but a secondary account is perfectly fine.

I’m not about to mess around with my graphics drivers/system start up programs/creating a 2nd admin user account to satisfy the generic troubleshooting when they aren’t problems the second I change Bnet accounts.

1 Like

Hey everyone i’ve had this issue for a couple weeks now and finally found a fix! for me i went over to battle.net(website) and disconnected any accounts that were connected to my account for me it was facebook and then went to privacy and communication and ticked everyone to enabled and i was all good!


This works!
Thank you so much for the help! Was struggling with this issue for a few days and couldn’t fix it no matter what… not sure as to why Blizzard has suddenly disabled all my comms but it’s working now! Thank you :blush: :pray:

:arrow_up: This works!
Thank you so much! Was nervous as I couldn’t find a fix for this problem, but going to the blizzard website and re-enabling all my settings has fixed it. Though, I’m not sure why blizzard had disabled all of my communication settings in the first place…

Can confirm what CharliePro says but you only need to tick in Privacy & Communication, Voice Chat to Listening/Listening & Speaking because for some reason it is off on some accounts which is why it produces Voice Chat Error 3.


Thank you CharliePro