The servers are trash!

Literally climbing the ranks and all of a sudden(40 ping BTW) I get disconnected and lost 50 SR. Thank u so much! What a wonderful game!!

2 Likes

god…you sound…like a child…and until a lot of people start reporting the same thing…you could just be a rare case

2 Likes

Blame ur internet not the server

It happens a lot more than it should on certain modem, routers.

Anything that has an Intel puma 6 chipset (which is a lot of brands during, maybe 2016)

It’s probably going to drop you from games about 8 times a month.

I had one, switched to a different one, never had the same problem again.

1 Like

but why, that is the question, is there something with what they did to their servers and how they interact with that chipset?

Because it randomly gets overloaded and crashes the connection.

1 Like

so is this an intel issue or a blizzard issue, or both?

what’s a good choice? we have alot of devices and our surfboard struggles to manage them all.

Intel issue mostly.

That said, I think instantly losing 50SR, should be replaced with 0SR if you reconnect win/draw, or -50SR if you reconnect and lose, or -50SR if you don’t reconnect.

Which is enough to prevent it from being abused, but still way better than -50SR for the guy who disconnected.

And everybody else gets to play a game of 6v6 with a strong inventive to win.

Versus a lame 5v6, with 12 people having a lame game of forced loss or free SR.

i get kicked out of the game faily often when i have low ping tbh

Unfortunately all disconnections and game crashes counts as leaving the match and will be penalized appropriately. The game server has no way to discern a legitimate disconnection or game crash from one that is forcefully caused by a dishonest player to bypass leaver penalties. You can learn about this policy here:

Remember if you see the message, “Lost Connection to the Server” in the title screen or the message “Failed to Connect to Server” in yellow text in the text chat box, this means there is something that disrupted your connection to the game server and not a problem with the game server itself. There can be a variety of reasons this happens including those that don’t disconnect your computer from the Internet. There is great troubleshooting to start with that can most likely resolve most issues and I encourage you to check them out here:

As always if nothing in that guide works, please reply saying you completed these steps and additional advice can be provided. Good luck!

(^^)v

You have any of these modem brands?

  • Arris SB6190
  • Arris TG1672G
  • Arris TM1602
  • Super Hub 3 (Arris TG2492LG) (commonly, Virgin Media)
  • Hitron CGN3 / CDA / CGNV series modems:
  • Hitron CDA-32372
  • Hitron CDE-32372
  • Hitron CDA3-35
  • Hitron CGNV4
  • Hitron CGNM-3552 (commonly, Rogers)
  • Hitron CGN3 (eg CGN3-ACSMR)
  • Hitron CGNM-2250 (commonly, Shaw)
  • Linksys CM3024
  • Linksys CM3016
  • TP-Link CR7000
  • Netgear AC1750 C6300 AC1900
  • Netgear CM700
  • Telstra Gateway Max (Netgear AC1900 / C6300) (Australia)
  • Cisco DPC3848V
  • Cisco DPC3941B / DPC3941T (commonly, Comcast Xfinity XB3)
  • Cisco DPC3939
  • Compal CH7465-LG / Arris TG2492LG (commonly, Virgin Media Hub 3)
  • Samsung Home Media Server

as far as i know, Nope

mine is a sagescom

I had 40 ping BTW lol