The newest update may be messing with my fps

ever since the(new havana map update) my fps has been 10 and lower. i tried using older nvidia geforce drivers, clearing overwatch cache, my settings are very low, window 10 updated. i think the newest update might have something to do with it, pls look into it? (in game tag=Bromadeinchi#2121)

oh wait, new nvidia geforce driver is here, let me try using it first ty

and theres another overwatch update, prob will fix it

nvm, it still hasnt helped, pls look into it!!

1 Like

This might be the reason?

i dont get black screens or crashes, n i dont have razer open while i play

Hey Bromadeinchi,

It might be worth a shot to fully uninstall any Razer products temporarily just in case. I had a contact earlier today where we fully disabled Razer products by selecting “exit all apps” but the problem persisted until the software was removed.

Keep in mind that removing Chroma software may actually cause black screens, as the original bug was that the SDK does not get removed / disabled even if the main program is. If this happens you’d need to locate the file “rzchromasdk.dll” in the system and manually remove it. This can be done by searching “My PC” for the file name.

If it’s still not working after that, please reply back with a DxDiag. This will help us further investigate what’s going on with the system to better assist you with FPS issues.

Be sure to also put the DxDiag in a code block like this!


I don’t got any of that razer stuff but me and two other friends have gotten some fps hiccups today while playing. my game is normally 100% smooth running around 60 fps on medium settings but today I got 5-6 instances where my game would bounce between regular and super low frames over the course of two seconds or so.

the fact that the Razer thing has worked for some people, but there are still way more who don’t have razer is frustrating, because it shuts down any attempt to address the underlying issue.

I’m in the same boat as the OP, since Havana released massive FPS drops, even to 0 fps. They do not appear in a custom game where I am the only active player, only when there are other players.

Thank u very much, it worked! i uninstalled all razer apps, i didnt manually disable rzchromasdk.dll though. ty again

The .dll file bit was only if you encountered black screen crashes after uninstalling the software. Sounds like you had the newer version that wasn’t affected by that bug. Super glad it’s working!!

For any users who do not have Razer software installed and are having FPS drops, please create a new thread.