Stuttering when playing longer


#1

Hello i am having stuttering problems when playing the game. The first few matches there is no stuttering but then it starts stuttering when doing simple things like moving around a corner. Things I have done are uninstalled all of my razer programs made sure to update to the latest version of my operating system which is Windows 10 version 1903 and update my drivers.


#2

There can be several causes for this, but the most common are overheating, bad RAM, and a failing hard drive or one without enough free space. You can use the windows tool to check your ram, and same for the hard drive with the disk check utility. For the overheating, you can use HwMonitor. I would normally link this for you but I’m on mobile atm.

P.S. I don’t work for Blizzard


#3

Nicole had mentioned it but as the issue occurs after playing over time, I’d recommend checking the temperatures with HWMonitor. You’ll want to run that while you play and until the issue occurs. Once that happens, take screenshots of the info in HWMonitor and upload them to an image sharing site like imgur to link here. You can get past link restrictions by encasing it in a set of ~~~ like so:

~~~
Link
~~~


#4

Hello I had cooling mode enabled on my laptop while playing and when the stuttering happened i took a screenshot of my temperature.
https:// imgur. com/a/3Qwt7Pn


#5

Hey there,

It looks like the GPU is clocked much higher than manufacturer suggested clock speeds. If this overclocking was not set up by you, please contact the device manufacturer for assistance resetting the device to default clock speeds. This should help with system stability.

The temperatures themselves look fine, this device should not have any problems with 65 C since it can handle up to 97 C.

Hope the info helps.


#6

Hi i have used the program HwMonitor and my temperatures seems fine I think I linked the pic in my earlier comment, I do have enough space on my laptop, I honestly dont know what to do next I feel like have tried everything, turning v sync on “solves” my problem but the in put lag is just too much for me to play, like that


#7

Mombo,

As Kaldraydis mentioned, it looks like your GPU is overclocked severely. Did you try disabling the overclock? Are you overclocking anything else? (CPU/RAM - even XMP overclocking counts here) - if you are, let’s set everything to default. If it works, you can always tweak the overclocks until they’re stable.

If you aren’t overclocking the GPU manually, does enabling debug mode help?

  1. Right click your desktop
  2. Click Nvidia Control Panel
  3. At the top, click Help
  4. Toggle on Debug Mode (it’ll display a check mark)

Any luck with either of those solutions? Does it improve at all?


#8

Hi

I have never done any overclocking with my laptop.
edit and I do not see those options in my control panel


#9

So is the debug mode grayed out or does it not even have that option?


#10

There is no debug option.
here is a screenshot:

https:// imgur .com/a/S0jQNi1


#11

Well that is interesting. There’s actually a ton of stuff missing from your Nvidia control panel. Can we fully reinstall the drivers?

  1. Download, but do not install the most recent driver for your graphics card from http://www.geforce.com/drivers
  2. Download Display Driver Uninstaller from https://www.wagnardsoft.com/forums/viewtopic.php?f=5&t=1788 (Click “Official Download Here” near the bottom of Wagnard’s first post. It will automatically download)
  3. Run the Display Driver Uninstaller file you downloaded and “extract” it to desktop
  4. On your desktop, click “Display Driver Uninstaller” and run it. Do not run in safe mode.
  5. Click “Clean and Restart”
  6. After restart, install the driver that we downloaded above in step 1.

If you’re still having trouble after this troubleshooting, please generate a text copy of your DxDiag using these instructions. Once you have that made, open the file. Copy the code below, then copy/paste everything from that DXDiag file between the rows of tilde (~) marks where it says “DXDiag goes here.”

~~~~
DXDiag goes here
~~~~

#12

Hi after doing those steps and i went in to the nvidia control panel to look for a debug mode but i still couldnt see it. I tried putting my dxdiag in this comment in a block qoute but it wouldnt let me it said i had too many words so i pasted mine in a paste bin
Edit: I’m also having stuttering issues
Edit 2 I see the debug option now I selected it but I don’t notice any difference in game.

https:// pastebin. com/7knMNCq8


#13

Mombo,

First up, sorry for the delay on this one. Apparently I forgot to hit “Reply” on my reply. x.x When I came back to check on you, this was what I had. If you still need help, please let us know.

Looks like you’ve got some windows defender errors and you’re getting “Radar Pre Leak” errors for Overwatch. Radar Pre Leaks happen when programs fight eachother most often. Let’s close any unnecessary background applications.

I’d also reset both your graphics driver and game settings.

Any luck that way?


#14

Ok so after doing the steps in the article I think my stuttering went away but im not 100% sure yet but my in put lag is still very bad when i look in the game (i press ctrl shift n) my sim number is 9-10 and im playing on the lowest settings with v sync reduce buffering set to OFF. I have included my new dxdiag file in my post

https:// pastebin. com/VUphNhvQ

My specs are GeForce GTX 1050 2gb, i5-7300HQ CPU @ 2.50GHz and 8gb

I did a test on userbenchmarks
and here is my result

https:// www .userbenchmark. com/UserRun/18081811

it told me that my CPU throttled at 99% i went in to a my power plan settings and they are set to high performance and my Maximum processor state is set to 100%.


#15

Oddly enough, this may be your hard drive. You have an exceptionally slow boot hard drive compared to the rest of your gear, at 5400 rpm. For high end gaming on a rotating platter drive, you tend to want at least a 7200 RPM high speed drive, or optimally an SSD. The rest of the gear in your computer is solid, but we aren’t PC techs so we aren’t going to be able to test them any further than what you’ve got there.

My best advice for you is contacting Lenovo support or a local PC technician and having them upgrade your hard drive. You’ll want one fast enough and large enough to run your operating system and main games off of. Lenovo may be able to help you configure the system to not throttle itself otherwise, but I suspect as long as you’re using a slower hard drive you’re going to run into periodic performance problems. They may also be able to recommend other upgrades or maintenance steps, like potentially upgrading the amount of RAM you have as well.


#16

Hello I know I marked this as solved but after replacing my old hdd with a new ssd (which is compatible with my laptop) Im still getting stuttering while playing the game.
Here is my dxdiag file:
My SSD is Samsung 860 EVO that I have replaced with my old 5400 rpm HDD. Everything on my laptop loads very fast like launching Overwatch or getting in to the hero select screen in the game.

https:// pastebin. com/j9V34AM9


#17

Mombo,

Thanks for the follow up on this, and sorry to hear the SSD alone didn’t get you fixed up. Can you run the userbenchmark again for me? I’d like to see if some of the throttling I saw earlier was resolved.

Beyond that, is your operating system now on the SSD? Did you do a clean installation of windows or copy anything over to the SSD when you got the new harddrive?


#18

Hello

Here is my result

https: //www. userbenchmark. com/UserRun/18361270

I coped everything from my old HDD to this new SSD so my OS, Overwatch, Battlenet. No I did not do a clean installation of windows.


#19

Hey again mombo2811!

Okay, so the good news is that it looks like the SSD fixed all the drive problems you were having, but userbenchmark is having trouble getting accurate data on your GPU. We can try forcing high performance mode to see if it fixes the stuttering, since you made some modifications to the PC. Usually you are not supposed to need to do this, and power management handles it, but every once in a while when nothing else works, this does.

  1. Right click your desktop and open Nvidia Control Panel
  2. Click Manage 3D Settings on the left
  3. At the top of the Global Settings tab there is a drop down which lets you select your graphics card. Use it to choose your Nvidia card.

Retest the game, and re run the Userbenchmark if you’re still having problems after all this. That said, if we can’t find the problem after all of these things, you may want to look into a clean installation of windows and all of your applications. It’s possible there’s some left behind corruption/damage to the install before you transferred it.