Stuttering each time i start Overwatch in the beginning

So each time i start up Overwatch it’s very laggy, stuttery even in menu for the past month or two

When i start a match for the first minute or two it’s stuttery nearly unplayable until it goes away

So now to prevent this happening in matches when i start Overwatch i always have to go Practice Range move around for a minute until it’s gone, then i can finally play whatever modes i want, which is annoying and a waste of timr

GPU - RTX 2060 Gigabyte dual fan
CPU - Ryzen 5 3600x
SSD
Windows 10 latest update

Tried uninstalling and reinstalling the game too which didn’t fix it, reported this at Nvidia bug report.

UPDATE: Finally fixed it when latest driver update download came up

I did Custom Installation instead of Express Installation and ticked the box at the bottom ‘Clean Installation’ :slight_smile:

Recommend you try this if you also come across the same problem i had

2 Likes

Same issue with all Nvidia cards. I have GTX 1080 Ti, RTX 2060, and the stuttering appears at first 3-4 minutes then stops. It’s probably some driver issue because doesn’t appear on my AMD cards

3 Likes

Thanks for confirming that, i submitted a bug report to Nvidia but haven’t got a response back yet

Can submit feedback here:

1 Like

I had luck with the July nVidia drivers.

1 Like

Damn we shouldn’t have to resort to downgrading to a near 5 month old driver

Just surprised Nvidia haven’t fixed this yet by now i seen on Reddit more and more people having this issue too

Damn Nvidia drivers incompatibility should be fixed ASAP Come on Overwatch this glitch/bug, must be fixed and is serious !!!

1 Like

It’s an nVidia problem, not a Blizzard problem.

edit - Updated OP it’s now fixed

the clean installation was what solved it for me too since just updating to 457.51 didn’t fix it

1 Like

A clean install did not fix this for me or others I know. Is this still an a known issue?

Clean install with Display Driver Uninstaller, or just nVidia’s app? The latter may not work as effectively as expected.

1 Like

Same issue here, 2 clean installs, no change. 1080 gtx, ryzen 7 2700x, the issue appeared since a few months, and nothing changed since then.
Can’t play like that in a game released 5 years ago. 5 years. This is just not possible.
It’s like the game is loading while I’m playing !! XD

Has anyone tried running Bnet in Administrator mode? That helped some others.

Hello, i had the same issue for months until i decided to figure out how to fix it. After reading on this post, i tried what Nicole suggested and it worked for me.

I basically did a full uninstall of nvidia drivers with DDU (Display Driver Uninstaller), restarted my computer, re-installed again Nvidia GeForce Experience and graphics drivers (GTX 1070), restarted my computer again and everything works fine.

1 Like

Thanks a lot, it did work for me as well.

It’s a shame it took this to fix the problem… I had given up the game for months it was so unplayable. Months XD.

Shame to hear that. I’m glad it’s working okay now though. It doesn’t seem to be an issue with Blizzard’s software itself, and more in the realm of how Windows or security software handles it.