Stuck on Applying Update on new Experimental Card

After queuing for an experimental match and finding one, the game tries to connect me to it, that’s when a screen pops up saying ‘‘Applying update’’ and it stays there in the main menu and I could see messages saying I will be kicked for inactivity until it says I’ve been kicked out. With the “Applying update” screen still loading regardless and it keeps on loading and loading until it eventually stops and says: unknown error (HF-2).

Now I have tried restarting the game and restarting my computer but I have not tried reinstalling the game because I do not want to have to wait but if that seems like the only option then I would probably do it.

I have had a what seemed like a successful updating process so I wonder why this is happening.

Any help from someone who knows how to fix this will be appreciated.

Update: The issue is gone now on its own. I think it had something to do with my internet connection because it was being a little bit slower due to my ISP having some issues connecting to certain servers at the time. I found out about that later when I contacted them.

1 Like

Check out this support page: https://us.battle.net/support/en/article/256854

3 Likes

Same issue, that did not fix it.

Same thing happened to me but queuing for competitive. Lost 50SR and couldn’t rejoin the game.

Did you check the link?

Please don’t hijack threads with different topics, and hold in mind that Customer Support does not manage any ingame balance at all.

Update: The issue is gone now on its own. I think it had something to do with my internet connection because it was being a little bit slower due to my ISP having some issues connecting to certain servers at the time. I found out about that later when I contacted them.