SIM SPIKES Please help!


#1

I run a desktop computer with:

-i7 930 2.8Ghz
-gtx 980 ti
-x58a chipset
-RAM 10gb
-OW installed on main SSD

So after few minutes playing or randomly I will have apparition of SIM spikes on a regular ticks. Like twice per second aprox. It makes the game unplayable properly and even hurt just watching. It comes with the sounds glitch at every spikes as well.

The task manager shows that my processor and graphic card are not even running 100pc to run the game as it very low gfx settings with 130fps caps so it s an easy job for the rig.

I just upgrade from a 960 to a 980ti and I had this issue before but it was very very rare. Now it s just happening all the time.

I have tried to set priority on high
I reinstalled drivers
I desactivated HTEP in BIOS
The power management is on performance
CPU throttle is desactivated
No other apps running, and even tho doesnt change anything

Please help as if I can’t fix this I will have to go on and stop playing OW :frowning:

There few screens of the spikes:

I am not allowed to post links or images but I have screenshots of the spikes


#2

There are a few good tips to try. First, try this article:

Next, please check your NVidia control panel for the following settings:
First, you need to set your Power Management settings to the high performance setting. If you don’t have a performance/quality setting already, you can use the left hand side of the power plan window to create one.

Now that this is done:

  1. Right click your desktop and go to Nvidia Control Panel
  2. Select Manage 3d Settings from the left menu
  3. Click the Program Settings tab
  4. Select the Overwatch Application in the list. If it isn’t there, Add it using the option next to the drop down
  5. In the options below, find CUDA - GPUs
  6. Set this to your Nvidia card, then click Apply
  7. Select Configure Surround, PhysX from the left menu
  8. Toggle the PhysX settings dropdown to use your Nvidia card.

Finally, reset the game settings to force it to pick up the changes.

I also have additional tips in my guide here:


Why is my traffic being routed through a Euro IP when playing in NA?
#3

Ok cool it has been sorted for now by reseting to default and seting the gpu for phisx


#4

Turn your FPS to max, lower your graphics, go full screen, done.


#5

Thanks for your help but it’s way more complicated than that. To the point I am not even sure someone can fix overwatch man.

FPS to max, lower graphics, go full screens. Thanks but I play FPFPS since 20 years bro that’s the first think I have done after installing.


#6

Sim spikes are not really an issue with windows 10 version 1709. Taimou is an idiot for blaming blizzard about sim spikes