"Show/hide replay controls = N": unfixable keybind conflict


#1

Problem with the new replays:

  • “show/hide controls” is bound to “N” somewhere behind the scenes and there’s no way to change this.
  • if there’s a conflicting keybind, (“spectate > move up = N" in my case) “show hide/controls” is bound to nothing. Even deleting the conflicting keybind won’t fix it.

The only “fix” at the moment is resetting all your controls. But that will delete all your custom keybinds, all crosshairs etc on every hero, so that’s really bad for people who changed their options a lot.

Proposed solutions:

  1. Let the players reassign the “show/hide replay controls” action in the keybind options.
  2. When this goes live, let the game check beforehand if you have bound the N key to any other spectator action.
    (I had bound the N key to 3 actions: “jump”, “endorse player” (both are fine, no issues) and “spectate > move up” (this spectator one led to the issue described above))

For more info see also:


Binding N || Timeline binding / not working
#2

Latest PTR Patch ( 1.37.0.0.58718 ):

The issue got slightly better, but isn’t fixed yet.

Now when you assign your N key to “move up” as in the example above, you get a keybind conflict warning message:

N has been removed from “media controls” and is now bound to “move up”.

https://i.imgur.com/rmseOBi.jpg

However said “media controls” option is still a hidden option, the player can’t change it yet.

So once N has been removed from the hidden media controls option there is no way for the player to fix this. (Except restoring all your settings to default which will delete all your custom hero settings, crosshairs and so on.)

Proposed solution: make the “media controls” option visible to the player so he can change it.


#3

This is happening to me (on live now). I can’t access the replay options at all. I’ve tried every key on my keyboard but none work. As far as I know I don’t even have N set to anything else. I’m super confused and annoyed because I can’t interact with the replay at all. I can only watch it like I’m spectating a normal game. I can spectate players by using F1-F12, but that’s all. I can’t pause it, change the speed, or anything else. :confused:

I really hope they make the keybind option for it visible.

Edit: Hopefully this isn’t too much later to comment on this. If so, I apologize.


#4

I have the same problem now on live, on owl viewer they have media controls as a bindable key in control settings, but not on live!!!


#5

Just checked through all of my controls and discovered I somehow had N as a second bind to push-to-talk. Unbinding it fixed the problem, I can now press N in the replay viewer to bring up controls!

Before I found that out, I did find that you can pause the game by pressing Ctrl+P. Kinda useful. If you can’t do anything else at least you can pause it. Ctrl+I (i) activates or deactivates character portraits on the map.

Still, the option to bring up replay controls needs to be viewable and a rebindable thing.