Screen flickering during games

Heya, been having a problem with two games in particular and I’m not sure what’s causing it. When I open Overwatch or Team Fortress 2, my monitor turns itself on and off repeatedly. In TF2, the problem isn’t too annoying, as it only happens during loading screens, once I’m in a game, it runs fine. In Overwatch however, the screen is flickering on and off every second, in menus, in game, etc.
I’ve tried reinstalling both games, and that did nothing, I’m starting to believe it’s a problem with my PC itself, as this is affecting both Steam and Bnet.
If anyone has any answers, I’d greatly appreciate it.

Hey Orochius,

Do you have an Intel Integrated card by chance? Try turning on Vertical Sync (VSync) and/or using Windowed/Windowed Fullscreen mode to see it helps with the flickering issue.

I turned on VSync, that unfortunately did not help
However, setting the game to Windowed fixes the issue. The only problem I get very easily distracted by applications I can see next to Overwatch’s window (notifications, things like that), I’d prefer if I could fix the flickering while in fullscreen.
I also attempted setting the game to borderless windowed, but oddly enough, it treats it as fullscreen mode and that of course, causes flickering.

Orochius, it sounds like that could be the Intel issue or Fullscreen Optimization on Windows 10. Let’s run through the full screen optimization steps:

  1. In the Blizzard App, select the Options drop down in the Overwatch tab and select Show in Explorer
  2. Right-click on Overwatch.exe and select Properties
  3. Go to the Compatibility tab and check the box ‘Disable fullscreen optimizations’
  4. Press Apply and OK

Finished!

If that may not do the trick, this is likely an issue with the integrated card. We’ll want to run through a Display Driver Uninstaller and reinstall the drivers from Intel.

  1. Download video drivers from your manufacturer (Intel) Don’t click on this installation yet! We’re saving this for later.
  2. Download the DDU tool from Wagnard here.
    Optional To yield better results, try it in safe mode. Press Windows Key + R, type in msconfig and under Boot, switch it to Safe boot and Networking. Restart! (Just uncheck Safe Boot under the Boot tab to undo the safe mode)
  3. Launch and extract the files. You should have something called “Display Driver Uninstaller” under the extracted location.
  4. Click on Clean and Restart.
  5. Once the restart is complete, install the driver from step 1.

Would you happen to know what video card is on the system and if there are any integrated cards, too? Just the video card (GPU) and processor (CPU) will help.

1 Like

Upon doing what you asked, I got slightly scared when this completely replaced my Nvidia Drivers and deleted GeForce Experience (I’m using a Nvidia GeForce GTX 1050 graphics card, with an Intel Core i5-7400 CPU @ 3.00GHz, if you still wish to know).
However, upon reinstalling the Nvidia Drivers, I tested Overwatch and Team Fortress 2, and this seems to have fixed the issue, I’ve gone several hours and a few games without any flickering in fullscreen. Thank you, I really appreciate this!

Hey Orochius! Thank you for the update, I’m glad to hear it resolved the issue ^.^

1 Like

It’s been a few days now, no issues at all, just in time for the PTR update, too!

I have same issue since months.

I uninstalled my gpu/display drivers. I did the “Fullscreen Optimization on Windows 10”. And even uninstalled my other softwares like CAM by Nzxt. Didn’t helped.

Here’s a video which I recorded one months ago.

Hey, Xanela! This thread is quite old. When uninstalling and reinstalling the drivers, was the Display Driver Uninstaller tool used? If not, it can help clear the drivers better than the traditional uninstall and reinstall.

Otherwise, could you create a new thread with DxDiag files between two (~~~~) to check out the flickering issue?

Locking this thread due to resurrection.