Retribution Game issues


Can anyone help me? I’m having issues where once or twice during the event my game randomly takes me back to the Arcade game screen; acting like my game crashed then it reloads my game like it just found a matching game; but it leaves me where I was standing before it happen in the game I was playing, and I notice right before this happens everyone is holding still or running in place and i cant kill or hit anyone.

Server Lost Connection-Console PS4
Can't get in the Retribution mode
(Cathy Lee ) #2

Hi Senshi!
Are you seeing this issue in story mode, all heroes mode, or both?
Do you mind telling me what router you use and the model number?


sounds like another event bug. There got to be so many that I started compiling a list of them here



Same thing for me. It’s only for the Retribution and Uprising game modes for me.

(Cathy Lee ) #5

Hey iiBabizx!
Thanks for the info! There’s currently another thread talking about this same issue and they posted a possible workaround if you have a Netgear router.

I’m trying to gather as much information about this issue as I can. Do you mind telling me what router you use and the model number?


Sure! I use the Netgear Nighthawk, R6700v2 . I hope this helps trying to fix the issue. Best of luck!


Can confirm the reddit fix worked for me:

us. forums. blizzard. com/en/overwatch/t/pve-disconnect-issue-solved-if-you-have-a-netgear-r6220-router-read-this/62185

detailed here as well.

Its an issue with this router in particular it seems.


Lets be clear, this may be a workaround. but this is still a problem on your end. I’m not buying a new router just because its the only way I can play what is otherwise broken game.

(Cathy Lee ) #10

Thanks so much for all the information guys and gals! We’re trying to reproduce the issue on our end and really appreciate your patience and cooperation. Can you also tell me if you were hardwired or wireless when you encountered the issue?

Blizzard client immediately disconnects when playing retribution: Legendary

I am also getting a problem of getting stuck in the loading screen of the Retribution mode only .


Yep, same thing happens to me same router (Netgear R6220) with a wired connection. Attempted the QoS fix by prioritising the TCP port 3724, however it didn’t seem to fix it. Wireless unfortunately isn’t an option for me. Any fix would be appreciated!


We just completed the Expert Difficulty on Retribution with a friend, and we didn’t get the “Quiet Night” achievement.
I’m not talking about the one that you have to not die (I believe its named “Clean Getaway”). The other one, in which you haveto just complete it on expert. Neither of us got the achievement.

(Cathy Lee ) #14

Hey Vishk!
Can you try prioritizing UDP ports 26503-36503 and let me know if that makes a difference.


After prioritising those ports i only dropped out once at a random point, whereas previously i would drop out twice consistently at the same point in the map. However, definitely an improvement!