[Reposted from EU Forum] Consistent Freezing Upon Death during and after Killcam (With Video)

This post below was copy-pasted from the EU forum post I made right here, because I didn’t realize I accidentally made my way to the EU forums before making my post. My bad. Devs, if you need to, feel free to remove whichever one of these you need to if you need to, just make sure to keep one of them up because I need closure on this bug.

Recently, I’ve been having random troubles in game with it automatically dropping me from the match probably from packet loss (which I can’t fix because I’m on dorm internet) and also my game deciding to freeze almost every time I die. I used Nvidia shadowplay to record when this was happening to me and I have two videos of it happening right here and also here where the first video left off. I’m gonna leave a list of interesting timestamps where it happens to me, and I want to note the strange behavior before and after the freezes, including incorrect/missing music, incorrect camera angles, etc. During the freezes, it can also look like the in game timer skips ahead, and I think that’s because Nvidia Shadowplay doesn’t record when a window is not responding in Windows. Anyway, in the first video, there are freezes starting at 0:34, and 4:25, and in the second video, it freezes and/or returns to the intro screen at 0:00, 0:15, 0:27, 1:00, 1:15, 4:55, 5:09, 5:36, 5:54, 6:00, 6:13, 7:31, 7:45, (at 8:23 I died and it didn’t happen), 8:50, 9:02, 10:29, and finally 10:41. It’s a lot of timestamps, and after writing this down, I seem to notice that the “map introduction screen” thing happens after every time that the game itself freezes, but just about 12-15 seconds afterwards.

Now, as for steps I’ve taken to try and fix this, I have:

  • Reinstalled my graphics drivers on a clean installation
  • Scanned and repaired files for my Overwatch installation (on Live NA server and on PTR)
  • Restarted my computer many times
  • And closed all other possibly interfering applications including Nvidia GeForce Experience and Nvidia Shadowplay

The things I have not yet tried that I suspect might make a difference:

  • Fully uninstalling and reinstalling the game (I will likely try it on the PTR build first to test)
  • Reverting back to using my GTX 1060 3GB (this is a last resort item though. I never experienced these issues on this graphics card, but I have only very recently been encountering the issues, as it’s been almost 2 weeks since I installed my brand new 980Ti without any issues previously.)
  • Underclocking/Undervolting CPU/GPU to test stability (I currently run stock settings on both my CPU and GPU, so I don’t think this would be the issue and would probably introduce more problems than it solves.)

Recent changes I’ve made to my system hardware:

  • Replaced system power supply with a higher wattage one to support…
  • New GTX980Ti, installed at the same time as the power supply about two weeks ago
  • Moved my RAM positions on my motherboard so they would support dual-channel speeds, I accidentally put one of my 2x4GB sticks in the wrong spot, and so I swapped the position of it and my 1x8GB stick so that my system would use the 2x4 pair in dual channel with the 1x8 in single channel, and I had also noticed previously that my system was bugging and reserving half of my total RAM for system usage before this and it is acting normally after this change.

I understand there are a loooot of variables in a situation like this, but I really want to find a solution to this, because until I do, it makes me completely unable to play competitive matches in fear of disconnecting from the match and being a detriment to my team. There’s simply too much to lose to be worth the risk of playing as long as this bug is still happening to me.

If you know you’re going to disconnect at school, the right thing to do is stop playing Competitive Mode while you’re there. It’s really unfair to your team to leave the games all the time, and could result in season bans after so many leaver penalties.

I watched all of both videos. It does look like your GPU is disconnecting/resetting, or that you are experiencing small connection interruptions. This is usually what is the cause of being able to see the HUD and nothing else, and having the map reload continually.

Here’s what I’d do to start troubleshooting:

Run a WinMTR while you’re online doing anything, for at least 10 minutes and post the results here with the </> button on the editor. Add spaces to links.

Get a DXDiag and also post it here, or on pastebin (can do this for WinMTR too and honestly it’s my personal preference). This will help us spot hardware inconsistencies, errors, and any driver remnants. Then we’ll go from there.

My bet is that it’s connection related, since your ping is flying down every time this happens, as if it just reconnected.

If you know you’re going to disconnect at school, the right thing to do is stop playing Competitive Mode while you’re there. It’s really unfair to your team to leave the games all the time, and could result in season bans after so many leaver penalties.

Exactly, I haven’t been playing competitive ever since the bug started happening to me. Today, it seems to have been less severe with only minor snags every death as opposed to full-on “not responding” freezes. I also live at the dorms, so that would eliminate me from playing competitive for at least the rest of the season if not longer if I can’t play while I’m living here, and I admit I haven’t been playing it often anyways but it still sucks. I’m going to run a WinMTR and do a DXDiag soon here in a bit and post the results on here and on the original post I made in the EU forum on accident. Before that though, I wanted to say I don’t think that it’s a connection related issue in its core, I think that the game freezing is stopping my client from sending data to the server and when it unfreezes, it somehow thinks I’m rejoining the match again which prompts the intro screen. Like I said above, I never encountered any issues like this when I was using my 1060 3GB before so it’s possible it’s a byproduct of my new 980Ti. However when installing my new card, I made sure to uninstall all Nvidia drivers and programs completely and reinstall everything once the new card was installed, and since then I’ve already done a clean installation of new drivers. Anyways, give me a little bit and I’ll see if I can get those logs posted here.

Editing the bottom of this comment to add what I was going to post in another comment but this forum is weird and doesn’t let you double post even for a good reason so here it is:

Here we go, here’s the pastebin for my WinMTR: pastebin. com/fa7gpv7p (link broken on purpose because I’m not allowed to post links apparently even though my original post had two)
I stopped it a little bit after it first happened, but I wanted to note that it wasn’t the major freezes like what was happening in the videos, it was more of a 2-3 second snag that happened after I died and waited to respawn.
And here’s the pastebin for my DXDiag: pastebin. com/y7FDMJZS
I’m not sure if there’s anything of note in here because it’s a long text file and I’m not gonna look through it myself if I don’t know what I’m looking for.

  • Have you updated your bios? There’s a known issue related to Ryzen hardware.

  • Crashes? Performance Issues? Known Issues Here!

  • Does shotcut have any sort of overlay that could be interfering? I see this app crashing in the error log.

  • Have you updated the audio drivers? Also, I know there was another post about virtual audio cable software, so I’d look into this as a possible issue. We’re seeing this error: “Sound Tab 4: The file vbaudio_cable64_win7.sys is not digitally signed, which means that it has not been tested by Microsoft’s Windows Hardware Quality Labs (WHQL). You may be able to get a WHQL logo’d driver from the hardware manufacturer.

  • Make sure to close all background instances of Chrome when you launch the game. Some users have experienced a conflict with the app, and I see a crash report from Chrome in the dxdiag.

  • Try matching your monitor and GPU resolutions/refresh rates.

  • Open the Properties for Overwatch .exe and Overwatch Launcher .exe and go to the Compatibility tab and disable full screen optimizations.

  • Make sure your 980Ti is a legitimate piece of hardware by using the GPUz app (it’s a small free app that will show you hardware details).

  • Double-check for malware with a tool like Malware Bytes.

  • Install the Windows updates that are reporting that they are failing to install.

  • I have not, I am a couple versions behind. I will do that in a moment. I had thought BIOS updates are done automatically through windows update but I guess not.
  • Shotcut was something I was using to try and piece together clips of gameplay I recorded, it seems to crash often as well as use a lot of CPU usage, but I’ve never used it with my game open at the same time, only after the fact.
  • That vbaudiocable thing is something I was trying to use to route my system sound in a way that I can record only the game audio but not other things like videos and stuff in the background. I haven’t made it work the way I want, so I can just delete them if need be. They’re a third party product that I’ve tried using before and I’ve deleted it before too, but I don’t see why that would cause an issue, especially since the bug has happened when the virtual audio cable devices were disabled in my sound settings.
  • I’ve had this bug happen with and without chrome open, and in the past before this started happening, I’ve had chrome open without having this bug happen.
  • My monitor is 2560x1440@144Hz and my graphics and game settings are set to the same
  • GPUz reports it as "NVIDIA GeForce GTX 980Ti and seems to properly recognize its details. I also purchased the GPU directly from the manufacturer on their website, so I have no doubt of its legitimacy, however it was a B stock product. It came properly shrink wrapped though, so I believe it was brand new.
  • I have Trend Micro, but I can check with another tool if need be.
  • And lastly, weirdly enough windows didn’t show it needed any updates when I went to the update tool until I manually clicked “check for updates” then it found one. It’s downloading and installing now. I’ll edit this post when I finish updating my OS and updating my BIOS and report back whether or not I still encounter the bug. Thanks for the help, I really hope this works.

Just add a new reply, it doesn’t alert anyone when you edit your own posts.

Alright, I’ve been testing it for a while after doing the BIOS and Windows updates. Aside from one or two times at the very beginning, I haven’t noticed it freeze at all since then. I believe that a BIOS update was all that was needed, but I will come back to this post and update if anything changes. Thanks for the help!

1 Like

Yeah, we had this bug a while ago after a patch, not only at AMD systems but Blizzard fixed these lockups luckily.
Since some days, my killcam sometimes skips, maybe a server-releated problem, not sure. But thankfuly no crashes.