Repeated Rendering Device Lost


I have been having this problem going on now for maybe 3-4 days now, prior to this the game ran just fine and it seems to only affect Overwatch. Around this time I downloaded the latest NVIDIA drivers as well as Windows update but other than that no other big changes or anything.

My graphics card is a NVIDIA Geforce GTX 1060 6GB, and as far as I can tell this dosen’t seem to be an overheating problem. The GPU reaches a temperature of about 65 - 75 and its often when it reaches those higher temperatures that the rendering devices lost pops up. From what I understand though that’s not such a high temperature at all.

I am at the end of my rope here and I feel like I have tried various methods and nothing is working.

I have tried removing old drivers and installing “Clean” new ones. I have tried cleaning the inside of the computer with compressed air. I have tried running an earlier version of the driver but nothing works.

You definitely hit up all possible troubleshooting that I would normally recommend so thank you for that. One last step I am going to recommend is to clear your game video settings then relaunch Overwatch. This will force Overwatch to build a new video settings profile based on your current driver version and setup.

Aside from that, I recommend getting the Power Supply Unit looked at…