Rending Device has been lost

Hi, Blizzard please help!!! I have been playing and before I get into a game, or after I finish a game, my screen freezes and I can’t do anything! When I push my windows key, I can get to my task bar, but not to any other programs, or to the message that Overwatch sends me. I can read it when it comes up in the preview and it says “Your rendering device has been lost! The application will close!” And it has been happening a lot, like three or four times in a row. I searched the forums, and I have tried everything they suggest, updating drivers, updating windows, searching and repairing overwatch, playing on low graphics setting, even ran a system file checker and repair. Nothing is working! What is happening??? Please help!!! I can’t play a game without it happening!!!

Have you try this standard troubleshooting yet?

Thanks, I actually had seen this article and had tried everything that I could, I am still experiencing the problem, but I have a ticket now, thanks again!