Rendering device has been lost?

Almost every time there is a new update, I get this popup “your rendering device has been lost”. I have dealt with this since the beginning and I’ve contacted support many times with no solutions. I have tried reinstalling my graphics card, overwatch, blizzard, etc, I feel like I’ve tried everything.

I wasn’t even able to play or enjoy the Halloween event last year bc of this. No one else I know has this issue either. I feel stuck and frustrated, this happens too many times to count and its always within the first 5 minutes of hitting play.

Which of these steps have you tried to fix it?

Hey, Catpotato! It appears that the GTX 550 TI is reaching 94-95C degrees which can cause the rendering device lost error. It might help to try debug mode on the TI, then monitor the temperatures with HWMonitor.

If you need someone to take a look at the HWMonitor, feel free to provide a screenshot here!

For graphics card, we generally want to see the temperatures under 80C otherwise it can start throttling and other issues with the system. The overheating could be due to dust or fan issues, but these situations do require a physical check on the system. If it seems like the issue may not be dust, please reach out to a local technician.