"Rendering Device Has Been Lost"

Recently I’ve been experiencing crashes where the error text says “rendering device has been lost”. I’ve tried updating the drivers of my graphics card and tried to use msi afterburner to decrease the the core clock but nothing works. This just happened suddenly, I didn’t do anything or update anything.
Sometimes I crash mid-game and sometimes I crash when I press the windows
key or alt+tab out when i’m in overwatch.
I have a Zotac GTX 1060 3gb graphics card which is just 10 days old.
Please, I need help.

I can’t help you, but I have been experiencing this too, constantly. I neither use a AMD driver nor a Ryzen driver, and have tried all the reccomended steps that Blizzard asks you to take. Nothing has helped.

Please help, Blizz!

hey guys, the AMD GPUs and Ryzen CPUs are just two common causes for this issue. Did you try all of the steps in the sticky?

It seems like the problem was my drivers. I updated them and now Overwatch runs perfecly.

1 Like

Which drivers did you update?

I updated my nvidia drivers to the latest version.