Render Device Lost

If i start OW in the Blizzard Launcher, then it will open in Fullscreenmode. (Everythings fine til now). But when i do something else outside the window, like pause my music in Spotify on my second screen OW will loose the render device after max. 5min. That is a Problem with the Launcher in my opinion, cause when i start OW without opening the Launcher it will work, even if i click something on my second screen. How can i fix this? I haven´t found a solution till now, expect starting it outside the Blizzard Launcher.

Thank you for your help yall.

Are you using an RTX graphics card by any chance?

Last month (second half of Nov 2019) I tried three RTX 2080 cards (different models):

  • Default card settings (no tweaking with AfterBurner or similar).
  • Other than the GPU, exact same hardware config:
    • No overclocking in the system (I never overclock anything despite having a MOBO with lots of OC options)
    • Decent mid-tier MOBO
    • Decent mid-tier PSU (850W - it can power my system during gameplay without cooling itself with it’s fans)
  • Same software config:
    • Same OS, and every other software
    • Same video driver that I always reinstalled after card swap.
  • Overwatch video settings that result in 60-80% gpu load during gameplay.

Only one of the cards resulted in “Rendering Device Lost” messages every few minutes, even in the main menu. It was the strongest (probably the most factory overclocked) card with a default GPU clock of 2100MHz compared to the 2000Mhz of the other two cards. In my opinion a default GPU clock of 2100MHz for an RTX 2080 is a bit steep, I’d worry about stability. Other non-2080 RTX cards might have similar issues.

Hey there!

Sorry for the late reply,
Could you check this Article for me? Let me know after you’ve checked and tried everything in there if it’s fixed or not.