"Render Device Lost" Fix for RTX


#382

posted that 8 days ago. havent had a single “rendering device has been lost” error since doing the overwatchtest renaming fix. its been approx 11-12 days. Thanks! :slight_smile:


#383

Renaming to overwatchtest.exe among other things didn’t work (rtx 2070 MSI Duke here). From what afterburner shows, my card is going well beyond boost and is trying to sustain past 2ghz, despite running on default or even underclocking. For other games, it tends not to attempt pushing past say ~1900mhz and is entirely stable. Despite undervolting and trying to cap performance, like 5 seconds after launching the game it revs up insanely hard.

At first, all I had was rendering device lost, but now it crashes the entire computer generally about 10-30 sec after login. Already checked and swapped PSU to test, because that was the first thing that came to mind etc.

Not sure what else to try. Have reinstalled both game and drivers, re-seated GPU, checked PSU, tried various settings and voltages with afterburner, other games run fine, etc


#384

That sounds like a hardware problem. Your best bet would be to RMA the card.


#385

Since having the render device lost error I’ve been paying a lot more attention to GPU temperatures and GPU usage. My RTX card seems to be very well cooled and thus the temperature part is boring but I noticed I always had long period of ~95% GPU usage that was a huge anomaly for the game.

The hero select screen is maxing out the GPU even though the game itself doesn’t while running at ~290 fps.

https:// i.imgur. com/6Iag9t6.png

Fixing whatever this issue is should drastically reduce the number of render device lost errors for everyone. (Almost all of mine happened during this time or during the PotG.)


#386

Odd. All of my render device lost errors happen during regular QP. I haven’t once seen a crash during hero select or during PotGs. My crashes are just extremely random and can happen any time during regular game play. It could be when there is just one other person on screen or when it is 6 v 6. With the renaming method I experience FPS drops at the same weird random intervals.


#387

[EVGA RTX 2070 Black] I’ve been using 418.81 as well for the last 3-4 days and launching from battlenet instead of using rename trick. Haven’t had any crashes so far.


#388

yo I just now had the render device lost bug. I was on mystery heroes when it happened


#389

Same here… no crashes since updating to 418.81 and launching from bnet (no renaming). Looks like they may have fixed the bug…


#390

Happened to me for over 2 months by now. Tried all the available solutions, nothing works. It’s only Overwatch. No other game does this. This is class action lawsuit by now. Blizzard is selling a defective product knowingly.


#391

I still crashed on 418.81, in fact immediately on updating to it and the first game within the first 60 s :frowning:


#392

On god this is ridiculous…I’m just trying to play some competitive but literally every time I load into the game I get “rendering device lost” and get banned. Currently I’m on an 8 hour ban and I feel horrible because it’s not my fault and my teammates pay the price. Please figure something out with this issue so I can just enjoy the game. Currently I’m running an RX 580 at factory speeds and i’ve even increased the fan speeds to keep the card running at a lower temp to avoid this issue, no luck with that either.


#393

This issue is pertaining to the RTX line of video cards from NVidia only. A rendering device lost error is extremely generic and it can happen with any card from any manufacturer but that doesn’t mean it is the same issue on your RX from AMD. If your video card had the same issue as the RTX does then the vast majority of people playing Overwatch would be reporting about this error, and this doesn’t seem to be the case.


#394

I haven’t crashed since using the OverwatchTest.exe trick and logging in manually bypassing Battle .net launcher. Just wondering when I can stop doing this? Still on 417.71 drivers though - I don’t really trust Nvidia’s drivers at the moment so I like to stick with what I know works.


#395

Renaming overwatch to overwatchtest has been working for me. Haven’t had a crash in over a week using this method. Will report back if that changes. Thanks for the temporary solution to this issue!

System specs:
Gigabyte Windforce OC 2080 TI
I7 9700k
16gb DDR4 3200mhz cl16
1TB Samsung 970 evo
CPU/GPU water cooled with an EKWB custom loop


#396

418.81 will still occasionally (for me its around 1 in 100 games) crash during the PotG with the same low temp, but 100% gpu usage as before.


#397

Guys, overwatch does NOT support overclocking AT ALL, so don’t do it. They have already said it!

Reset overclock settings for overwatch, you won’t get this error anymore!!!


#398

Hi Drakuloth,

I am a very stubborn person and I own a GTX1070. And I tried your solution which is actually meant for RTX users.

And it actually worked. I finally play Overwatch for 2 weeks without any crashes!!

It seems that your solution also works for GTX 10 series. I am very happy with the solution (Which was not meant for me). :smiley:


Render Device Lost
#399

Thanks for sharing, at least it seems like theyre getting somewhere.


#400

this have been passing to me with RTX 2060, only with overwatch, none of my other games gets a similar issue, 1st day got it like 5 times, then stopped to happen magically for like 6 hours, then this saturday played with 0 issued, then yesterday started to happen every 2 games, i underclocked the memory and stopped to happen for the day, i will see if this still happens or not, but this is something that i see have almost 2 months and not a real fix =(


#403

How long do I need to keep using the OverwatchTest.exe method? I never know when the game has updates now. I have to randomly log into the Battle .net launcher to check for updates - this ends up creating another Overwatch.exe file in addition to my Test file.