Random FPS drop after the client has been opened for a while

OK, I know there are dozens of threads about this my situation looks like it’s something different, slightly at least.
I run a solid 140-180fps configuration with a ASUS GTX 980TI OC+ GPU but sometimes after the client has been opoened for a while the frame rate halves and I need to restart the client.
Now I’ve read that in 2019 there were issues with razer chroma periferals and INDEED i have mouse + gaming keypad and headset,(both Synapse2 and Synapse3 installed) but I keep basic spectrum lighting and no Overwatch dedicated effects…
So i’m wondering if the Razer issue is still a thing…and how to fix it, thanks.
This also happenes a lot more frequently when i use a dual monitor configuration and I switch i borderless windows going from OS to OW often.

1 Like

It is still a thing. The solution is to completely remove all remnants of Synapse 2 and use 3. Known Technical Support Issues - Updated Dec 8, 2019

If manually removing the last of the Synapse 2 files mentioned in that post doesn’t remedy it, you may want to look for temperature spikes with HWMonitor. These can throttle the hardware off/on to control overheating.

OMG, can’t use my keypad configuration without Synapse 2…
I went from Steelseries to Razer because the Arctis 7 stopped working with Overwatch…

Did uninstalling resolve the issue? If you reinstall the software, does the issue come back? I have seen a good number of cases where reinstalling fixes it.

Let us know how it goes!

I will try that, but I think thgis might be a different case because I noticed the longer I keep the client opened the lower the performance goes.
They degrade over time falling evem below 60 fps from 160.
Something is not right.

I absolutely recommend using HWMonitor. Play for a bit, take screenshots of the HWMonitor window with all hardware expanded, and post on Imgur. Share the links to the images here and someone can look them over.

OK I installed HMonitor and see how it goes but I doubt it’s overheating, I don’t overclock and have a gigantic ventilatiion system.
One thing I need to know: these Razer software issues are with Synapse 2 o Synapse 3? Or Both?
WHat about Steelseries? I’m thinking about changing my whole gear setup.
Thanks.

To my knowledge, only Syanpse 2, but not 3 beta.

I’m not personally having any issues, but if you already switched the Synapse version, and the problem persists, then it’s not the issue and something else is causing your fps loss. Can you also add a DxDiag here?

Click here to show/hide DxDiag instructions
  1. Press Windows Key + R, then type DxDiag and press Enter.
  2. In the DxDiag window, click Save All Information.
  3. Name the file “dxdiag” and click Save.

To add it to your reply here:

  1. Open the text file and copy all of the text.
  2. Paste the text in your reply.
  3. Highlight the pasted text and click </> on the post editor.

If your DxDiag does not fit in one message DO NOT shorten it. Instead, post it on Pastebin.com and provide the hash code (the numbers/letters after the .com) in your reply.

Look I tried these steps:
1)Uninstalled both Synapse 2 and Synapse 3
2)Reinstalled only Synapse 2 otherwise my Orbweaver would not function with prog keys.
3)Tested 2 hrs of gameplay and fps was stable between 140-200+fps with CPU and GPU temps with norm params. It would usually drop a lot faster than 2 hrs.

Unfortunately without synapse 3 I can’t use the Razer Nari headset as the mic looks like it’s not working so I’ll try reinstalling Synapse 3 and see how it goes.
BTW stay away from Razer products, the hardware is cool but the software is garbage.
If I can I’ll give mine back.

Synapse 3 shouldn’t be causing any issues. If you add that DxDiag, maybe it’s something else we can spot. I know the Razer Game Scanner module is often the culprit of fps loss (it’s something you can disable).

I dont think I have something called Razer gsme scanner on my installation…
How do I attach the DXDiag, the text is HUGE.

instructions from above:

This is the hash code: Kmrpdcf8

If you scroll to the bottom of your report, you can see each app reporting an error (there are many).

It’s likely one of these two apps causing the issue:

Firma problema:
P1: Razer Synapse Service.exe
P2: 1.0.0.0
P3: 5e096456
P4: RSy3_LightingEffects

Firma problema:
P1: THXHelper22AD.exe

OK but I have no idea on how to fix them, this PC is pretty clean.
I can try to reinstall the OS and everything else…
I don’t even know what this is: RSy3_LightingEffects

It’s part of Razer Chroma.

Fresh OS reinstall and only Synapse 2, played for two days with no issues.
Today I instaled Synapse 3 too, I will update as results come in but I can tell Synapse 2 was not causing issues.

I found out the culpript, it’s the Razer Chroma Studio.
After removing that, everything worked again.
Synapse 2 and Synapse 3 can cohexist no issues…
I lose some advanced RGB functions but what the hell, it works.
Bad Razer software after all.
Oh the Razer Chroma app is turned off both on S2 and S3.