Random Crashes Mid-game

I recently bought Overwatch, and have run into an issue wherein my game goes to a randomly colored screen (most frequently black or white, but more recently a light teal and beige color) at random points during any match. My audio will stutter and then either go out or continue looping the same millisecond of audio until I force my computer to shut down. Attempts to alt+tab or ctrl+alt+del out have so far been unsuccessful.
I’ve turned off every overlay I can think of and play Overwatch with all other processes turned off; Steam, Discord, GeForce, the Battlenetlauncher, etc., all closed before starting the game.
I’ve double checked to make sure my drivers are updated and they all seem to be.
This issue has not occurred in any game I’ve played before or since other than Overwatch.
Any help anyone can offer would be much appreciated! Thanks in advance.

I can’t seem to post links here, but my DxDiag information is on pastebin (/k1vs5b9K), and my MSInfo file is too large for pastebin to accept, so if anyone knows a workaround for that it would be much appreciated as well.

There are a few errors happening in your dxdiag. Most notably is a CPU error, which you might find more information on in the Windows Event Manager under system logs. You also have the Windower app, which I’m familiar with, crashing a lot in the background, so it could be interfering with Overwatch (since Overwatch already supports a Windowed mode). You also have a Windows update that has failed to download or apply. And finally, you have a tablet connected, which causes problems for some people with Overwatch.

Thank you very much for replying! Unfortunately I’m still not having much luck with getting the game to run properly, however. I could only find one error in the Event Viewer’s system logs, and I did some cursory googling to see if it was something I could do anything about, but the solutions I found didn’t help much. I’m still crashing, but the earlier error has changed - I’ll put both of them at the bottom of this post.

I did unhook the additional hard drive I had which had Windower on it, though I’ve not been using Windower with Overwatch, and I don’t have my tablet connected but did run through and double check to exit the background process it runs even when disconnected before starting Overwatch this last time, just in case I’d missed it prior. I also managed to successfully install the Windows update that had apparently failed to properly install earlier.
The same issue is occurring - I’ve only gotten the black screen so far, no white or other fun colored ones, but I’ve also only tried to play a couple times since as the leaver penalty has kicked in for me now due to the crashes. The crashes also seem to be coming more quickly, as I cannot finish a game now - before I was able to finish at least a match or two before a freeze/crash occurred.

Original Error

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{6B3B8D23-FA8D-40B9-8DBD-B950333E2C52}
and APPID
{4839DDB7-58C2-48F5-8283-E1D1807D0D7D}
to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

New Error

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{D63B10C5-BB46-4990-A94F-E40B9D520160}
and APPID
{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
to the user Wes SID (S-1-5-21-4040193784-3421404326-967010053-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Evidently this is a permission error, so it seems like something you have running to protect the system might also be preventing you from running the game properly. There are a lot of links of how to fix the permissions, but it’s beyond my normal scope of troubleshooting since it’s more involved and I can’t be responsible for someone tinkering in system files/misunderstanding any directions.

Just to be sure, did you look over the known issues thread, too? Crashes? Performance Issues? Known Issues Here!

Hello WesBing!

To build off Nicole’s observation about the permissions, here are some things to try.

We can try running the game in administrator mode:

Administrator Mode

We can also check a Windows-level permissions setting, which our programs sometimes need to request file access and editing permissions (namely the game’s installed files and configuration files).

Secondary Logon Service

Please note that this requires a reboot to take effect.

Beyond this, we’ll want to make sure no other programs are interfering with the game’s processes in the background. The following steps will reboot into a ‘light’ mode where only the bare essential programs are running:

Closing Background Applications

After rebooting into this mode, please retry running the Battle.net app and playing as you normally would.

Then if the game works correctly, you can refer back to the article for advanced steps on figuring out which program is interfering.

Thank you very much for your reply! However, the issue is still persisting - I’ve gone through every step you’ve listed off, yet I still can’t seem to get more than two minutes into a match before being forced to reboot. The same system error is persisting.
I’ve also tried another suggestion I found through another bout of frantic googling (reducing the max processing rate by a single percent), but still no dice.

And you’ve disabled any antivirus software? Also reinstalled?

Yep, and I just uninstalled/reinstalled with admin mode on Battle net - got to play three games, more than I’ve been able to so far, but still crashed in the middle of a match.
On the plus side, I seem to have fixed the errors that were coming up in the event viewer! The downside is that they don’t seem to have had any relationship with the issues playing Overwatch, and now there’s no error beyond the usual “computer didn’t shut down properly” one that shows when I have to force it to reboot, so it seems to be back at square one.
And I’m very sorry for not replying back to your previous reply! I have gone through the Issues/Crashes thread and tried every option that applies to my computer to little avail. Kinda thinking Overwatch and I just ain’t meant to be, haha.
Do you think posting an updated DxDiag might help?

(Thank you so much for all your help once again - even if I can’t get this desktop working I am thankful to y’all for your kindness.)

This is a really old post on the EU forum, but I’m wondering if it might help? https://eu.battle.net/forums/en/overwatch/topic/17611931540?page=2#post-30

Also, have you checked the temperature on your card? You can look at it in-game with their UI options.

I tried a couple of the suggestions in there - namely lowering my resolution, lowering my max processing rate, and playing in windowed mode instead, all to no avail.
My temperature seemed to max somewhere around 80 when I was playing, so I’m probably gonna go ahead and clean the fans when I can get my hands on some compressed air.

EDIT: Updated DxDiag pastebin ( /SLznxeJX )

Wanted to add that WesBing and I troubleshooted this off the forums and it seems that their GPU is overheating, which is what caused the issues.