Poor performance with 1070 and 6700k


#1

While waiting in spawn room my fps is always at the 300 limit, but during fights i see it go as low as 100 fps, and i notice it because i have a 144hz monitor. I have oc’d my 1070 and 6700k by about 200mhz and have performance fan profiles. I looked at yt benchmarks, and a 1060 can hold 250-300 fps on low settings


#2

This game currently has an issue with computers “System Hardware Timers” and Prioritizes use of HPET (High Precision event timer) which is a compatibility timer over RTC (Real Time Clock with a battery inside your pc) and your CPU’s TSC (Time Stamp Clock) The Problem is with HPET is it runs absolutely horrible with this game for some strange reason and is meant for keeping more accurate time in case any of those other functions fail such as on server use this fixed all the issues i was having i hope it fixes yours.

in order to fix this issue try :
In WINDOWS run this command as admin and restart your computer go straight into bios and disable HPET , This Command will delete high precision event timer from launching on start up by disabling it from the Boot Configuration Data (Windows). This will force windows to run on TSC and RTC as windows uses all 3 timers (4 if windows 10). for some strange reason the game or windows picks HPET as the primary timer which is what causes this issue.

WINDOWS KEY + R

bcdedit /deletevalue useplatformclock

The Opposite of this command is :

bcdedit /set useplatformclock true

So if this fails to fix the issue go ahead and run the /set command then restart the computer go into bios and reset it back on, that way you have a way to start out normal.

Steps in case you get lost:

Disable HPET Priority in Windows
Restart
Go Into BIOS
Disable HPET IN BIOS.
Save and restart.
Launch game and enjoy :]

#3

Did this work for you?


#4

I ran this fix on my 6700k with 1080 TI and i went from 160 and sometimes on some maps 100 fps that wouldnt even change, to 300 FPS on Ultra, now i can play on Epic with 280+ FPS at all times on 1440p. I’ve been suggesting it a lot to others because the difference was really really night and day for me.


#5

Will def give this a try and let you guys know if it works😙


#6

sweeet I’d appreciate it if you came back and told me the results of it i hope it helps.


#7

Yeah it helped a little but not what i was hoping for. Dont know why i cant turn it off from the bios


#8

These standard tips can help resolve most Overwatch FPS drops:

Also here are advanced tips I have written in Overwatch’s Tech Support forum that maximize your FPS performance in the game.


#9

What’s up ya’ll.

My system specs:

i5-4670k @ 4.2
8gb 2x4 mushkin ddr3 1600 cas 7
asus z97-a
samsung evo 850 250gb ssd
evga gtx 970 - (no overclock)
asus vg248qe - 144hz

I recently acquired a gtx 1070 to put into my machine. To my disappointment, I saw at most, a 10-20 fps increase in regards to my minimums/dips and avg. Utter bullcrap, SO MAD.

I overclocked my DDR3 1600 to 2133. My lowest FPS dips went from 120 to 150.
My avg fps went from 170-190 to 190-220, and i was maintaining 240+ in many situations that i wasn’t even getting 200.

Due to the positive results of my testing, I went and bought 8gb (2x4) of DDR3 2400 C11 Corsair Vengeance Pro. I slapped it into my machine, good lord the results.

My MINIMUM FPS/DIP POINTS are now 190-200. My avg is easily 240+. I decided to do a little more testing, I just now overclocked my ddr3 2400 c11 to 2666 c12. I have yet to see my FPS drop below 240. I maintain 280+ more often than not. Im sure the FPS gains/avgs/minimum will and can continue to improve.

Im not 100% sure if this is the same for ddr4. But as far as i know and can prove, ddr3 ram speed is DIRECTLY related to maximum fps for high end machines.


closed #10