Player is in another version? cannot invite friends

Not sure whats going on there but, when I mouse over my friends to invite them in ow2 right now, it says “player is in a different version of overwatch” and i mean how is that possible we both downloaded the same prepatch u just gave us to dl


It’s a bug if you check the versions on Bnet and they match. In that case, report in #bug-report

im getting the same issue. we both waited like an hour to get into the game and now it says we’re on different versions? client versions are the same.

1 Like

I was having the same problem, but my friend was able to invite me to a custom game. They unfriended me and invited me using recent players, it’s tedious but it works for now.


having the same issue, both of us have updated, restarted, and scanned for integrity nothing is fixing it.

Thanks! This works<3

this is the only thing that worked. What a dumbass bug.

Hey guys! I’m having this bug as well. However… I figured out a way to bypass it for now - without having to remove a friend from your friends list. You can manually type: /invite playername, and it’ll fill out your friends # tag at the end (if it doesn’t you can type it). That works for me. Hope this helps the rest of you!#


Hey yall!!! just letting you know i found another fix!!! have your friends logout then log back in, as they are logging in you will have a moment of being able to invite them. it just worked for me and my 5 man!!

Restarted my pc and came back, I was logging in when my friend invited me so the reply above this one may have been the solution

(post deleted by author)

Seems you can invite friends from the chat dialog as well.

i found a fix for anybody struggling!
dont restart your game or u might get stuck with errors again!
i found out u can still invite your friends if you type ’ /invite [NAME OF UR FRIEND] ’ in chat.
hope this helps!


thanks for the fix. this bug is so dumb <3

Thank you sir, you are the MVP. It would be great if the tech support could give a helpful answer like that.

i love you man
i will sed you pics

No problem. The dev posting it was a bug made me wonder if the invite command would work or not, so I tested it out and was happy to see that it did. Glad it helped!

Had the same issue today. /invite fixed it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.