Overwatch no longer launching

I recently started having issues with overwatch not launching. when I click “play” the button will change to “Playing now”, one of my monitors will go black, and then it will go right back to “Play”. The only change I have made to my PC (that I can think of) is installing a second monitor. I’ve reinstalled my graphics card,reset in game options, reinstalled overwatch and battle net, cleared both local cashes (Battlenet and overwatch), checked for windows updates, rebooted, and I’ve even unplugged one of my monitors from my graphics card… nothing has helped thus far.

I went through the troubleshooting on the forums and tried all of the basic work arounds and none of it seemed to help. The only thing left I can think of is maybe I have a service stopped that is preventing it from launching?

Try clearing out the BattleNet cache:

If that does not work, try reinstalling BattleNet App Luancher itself:

Did both suggestions; Overwatch still not launching, might be related to my Nvidia driver update but I don’t know what else to try… :confused:

1 Like

Can you add a dxdiag here?

Click here to show/hide DxDiag instructions
  1. Press Windows Key + R, then type DxDiag and press Enter.
  2. In the DxDiag window, click Save All Information.
  3. Name the file “dxdiag” and click Save.

To add it to your reply here:

  1. Open the text file and copy all of the text.
  2. Paste the text in your reply.
  3. Highlight the pasted text and click </> on the post editor.

If your DxDiag does not fit in one message DO NOT shorten it. Instead, post it on Pastebin.com and provide the hash code (the numbers/letters after the .com) in your reply.

Please refer to this pinned thread for steps resolving issues related to Razer Chroma:

1 Like