Overwatch goes black when launching game help!

I get a message that says “your rendering device has been lost”. i tried everything online, updating windows, updating drivers, scan and repair feature, deleting the cache etc. my system is not overheating. i opened up modern warfare so its not a battle .net problem, i can open and run other games its just overwatch. i uninstalled and reinstalled but nothing. im hoping someone here could help me out thanks!


In my case the game starts but then everytime i try to get in a game is says “Failed commection to server”, sometimes even puts me in a game but i cant select a hero…

Just more blizzard being blizzard and not caring

Hey Pops,

A lot of things can cause these errors even for a single game. If you have tried all these steps, then please provide a DxDiag so we can take a look:

  1. Press Windows Key + R.

  2. Type DxDiag and press Enter.

  3. In the DxDiag window, click Save All Information.

  4. Name the file “dxdiag” and click Save

  5. Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the “code” button (</>). That’ll make the information much more readable.

It should look like this.

If you have issues pasting here, please use Pastebin and post the link (ex: Pastebin (dot) com/123456).

3 posts were merged into an existing topic: [Nvidia driver 445.75] Rendering device lost


Hey Pops,

I noticed you have Razer hardware. Have you tried these steps? I also noticed that you are getting Bluescreen errors 124. These types of errors typically indicate a deeper hardware problem and you may want to contact Microsoft or a local PC tech. In the mean time you can try these steps.