Overwatch game chrasing after 2/3 minutes ingame


I’m a new player playing this game. I was very excited to play this game. But i chrashed after playing a practice tool or co-op game in 2/3 minutes. First i thought it was one time only, but it happened over and over again. The message he gives to me : Your rendering device has been lost! Application closing!

I tried several things on the internet that could help, but none worked.
Maybe someone of the technical team could help me what to do.

This is a courtesy error from the Overwatch client to let you know your GPU is not functioning as it needs to for running the game. Sometimes the problem can be resolved with a clean install of the GPU drivers. Other times it can be spotted in a DxDiag.

However, if neither of those is successful and the issue is related to overheating or faulty hardware, you would then seek assistance from a local PC technician.

I’ve read some other things on the forums about the Dxdiag. Thats something i didn’t try yet. What do i have to do for this? do i’ve to copy paste it into here, so you could help me whats wrong?

Maybe. It depends what’s in the DxDiag :). Did you do the clean install of the drivers?

System Information

  Time of this report: 7/13/2021, 17:11:28
         Machine name: DESKTOP-9BU2EMT
           Machine Id: {B9C0BBA0-1E27-458C-AAC5-5BD00CDDE495}
     Operating System: Windows 10 Pro 64-bit (10.0, Build 19043) (19041.vb_release.191206-1406)
             Language: Dutch (Regional Setting: Dutch)
  System Manufacturer: Micro-Star International Co., Ltd.
         System Model: MS-7B33
                 BIOS: 1.40 (type: UEFI)
            Processor: Intel(R) Core(TM) i5-9400F CPU @ 2.90GHz (6 CPUs), ~2.9GHz
               Memory: 8192MB RAM
  Available OS Memory: 8132MB RAM
            Page File: 6627MB used, 9439MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 96 DPI (100 percent)
   System DPI Setting: 96 DPI (100 percent)
      DWM DPI Scaling: Disabled
             Miracast: Available, no HDCP

Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: 1.0.8
DxDiag Version: 10.00.19041.0928 64bit Unicode

Missing most of the report. Try using Pastebin.com instead.


(Sorry if some stuff is dutch)

There are no specific Overwatch crashes in that report, only errors about Windows updates. Have you manually checked for those? You might be able to review your MSInfo error reporting to see which app is related to the Overwatch crash.

Today my video card chrashed and didn’t work anymore. So the problem was with that all along. Now it works (with a new one) perfect and i can play the game. <3