Overwatch Crashing Entire PC

Recently Overwatch has been crashing my entire PC. I’ve updated my graphics and power supply a decent amount. However, even in low settings the game crashes. It only happens with Overwatch too which is weird. Here’s what I have going on:

Processor: AMD FX™-4300 Quad-Core Processor (4 CPUs), ~3.8GHz
Memory: 8192MB RAM
Card name: Radeon RX 580 Series
Power Supply: 600W

PasteBin: nMJy5wak

Please let me know if you have any idea what’s going on. Part of me is thinking it may just be the power supply needing a greater update. But if that were the case shouldn’t every game I play having issues? Not sure. Let me know what you all think.

Hey Kushmeister,
Could you please provide some more information other than “crashing my entire PC” ?

For example

  • The image on screen locks up and you cant do anything, have to hard reset.
  • The screen goes black but the PC is still [on or off]
  • You get a blue screen message
  • Overwatch crashes and you have to reboot your PC to be able to use it after the crash

Just some more information on how it actually crashes would be great, it will let people give you ideas on what’s going on or what to try next.

Usually the screen goes black and the PC is still on. The last time I tried it on low settings it said rendering device lost, memory failed. Twice it has completely shut off my PC, but that was with the old power supply. This current power supply was bought today.

What other games do you play?

Even with today’s brand new game titles by comparison, Overwatch can be VERY intensive and is also extremely specific about the responses it gets from your hardware. If it doesn’t like it, it can crash quite easily.

Might I recommend running FurMark on your PC for as long as you can (2-3 hours minimum) and noting down your temperatures using an app like CoreTemp/GPUTemp to see if perhaps your machine is overheating at the time?

I have the in-game temp stats running and it was at 60-65C when the PC gave up on me.

I’ve been playing this game completely fine actually up until I got a new chroma keyboard. That’s something I forgot to mention in the original post. I no longer use any of the associated apps since I thought that was causing issues.

I would suggest a stress test.
Also, have you repaired your game files?

Well that’s what has gotten me here.

You’re going to need to be much more specific, sorry. Can you please elaborate on exactly what you’ve tried?

From DxDiag:

Device Name: Razer DeathAdder Chroma
Attached: 1
Device Name: Razer Cynosa Chroma
Attached: 1

Your issue is likely related to the Razer Synapse software. Let us know if this helps.