My Overwatch Doesn't Seem to Work

After the Update for Hammond or wrecking ball, i wasn’t able to log onto OW. I found out i can uninstall and then reinstall the game. When i did that, i couldn’t log into OW through the blizzard launcher but i could by manually going into the files and doing it. That seemed to work and i was content with that. The next day (today) i tried logging on through the same way. It didn’t work this time, and i’ve been trying for hours to fix it and it still won’t. Can someone please help me fix this cause i don’t wanna spend another 60 dollars to get it nor do i have the money atm. Someone please help.

Where are you connecting from?

if you mean region i am coming from the NA, idk what you mean other wise

What’s happening when you try logging in through battle.net?

Ill click play and itll start loading then just stop

similar issue as well, played yesterday on a different computer everything was fine. Freshly installed on a new tower, game loads says it is running pulls up a black screen of OW. The screen immediately disappears and about 20sec later the launcher updates and currently playing changes to clickable play button.

Try running the Scan and Repair utility in the Battlenet launcher, and updating your graphics drivers.

I’m having the same issue. Worked fine until loaded the hammond patch yesterday (first chance), and it wouldn’t load. ran the repair - no issue found. deleted it/reinstalled this morning, and I got into it just for a training session - to try it out before work - and i noticed it seemed…slow to load, but at least it started. but when i tried to launch the game now, it’s not launching. it’ll either open a black screen and not load, or just say “Running” and not do anything.

back to report scan and repair had no affect on the issue.

I see some people talking about the repair thing, where can i find that?

Okay, my next suggestion is to try the steps offered here in their support docs: https://us.battle.net/support/en/article/26054

Or in this thread: https://us.battle.net/forums/en/overwatch/topic/20759258711

i checked for updates to see if it was just looking for one, but now all it is doing is saying looking for update and its been doing that for about 3 hours now

What was looking for an update? The game? Your GPU?

the game. So now the game has changed the weird things. Now itll open up and go to the thing but not its really slow now. and itll open but wont do anything

Hanksta, your issue sounds different from the one addressed here. Try searching for “black screen” as there are plenty of threads covering this issue.

What weird things are we talking about here?

Going to need more detail here. Go to what thing?

sorry i was quite rushed while typing that. The answer to the first things is this. Now instead of not loading when i click play, the game will start, but will take about 5 min to start to the screen that will take you to the game. But, itll never load, itll get to the screen where it loads the game but will crash. But my wifi is fine. i suspect this might be something on my end. The answer to the second thing i said is this. When i said “the thing” it was referring to the loading screen for the game. Like i just said, itll open this screen after 5 min, and will take another 5 min to get to this loading screen. Then, the screen will start loading but stop for no reason like a previously said. If you can help me with this that would be great.

It is Dec. 7 2018 and I have the same Issue I reset my computer and reinstall my overwatch game I have my GPU and all software up to date windows 10 etc and. When I click ‘Play’ the game flash and it closes real quick it wont even let me go on game menu the entire game just crashed or close. I delete cache nothing works I launch other game ‘Diablo3’ works fine only overwatch have this issue. dissabled nortorn and other firewall/anti virus it don’t work.

Hello Allan!

I’m going to lock this thread since it is many months old, and not relevant to the issue you’re describing. Your symptoms sound similar to issues we’ve seen with an old version of the Razer Chroma app. If you’re using that, please review this post for recommendations.

If issues persist, please start a new thread and we will catch up with you there :slight_smile: